Service DEF System, see dealer....

Service DEF System, see dealer....

This is a discussion on Service DEF System, see dealer.... within the RAM 1500 Diesel Mechanical forums, part of the RAM 1500 Diesel Garage - RAM 1500 Diesel Mechanics Corner category; Anyone seen this CEL pop up (Service DEF System, See Dealer)? If so what was the outcome. I did a search on the forum but ...

Page 1 of 6 123 ... LastLast
Results 1 to 10 of 56
Like Tree4Likes

Thread: Service DEF System, see dealer....

  1. #1
    RAM Sr Member Cheddy's Avatar
    Join Date
    Aug 2014
    Posts
    145
    Member #
    2370
    Vehicle
    Big Horn Crew Cab
    Liked
    57 times

    Service DEF System, see dealer....

    Anyone seen this CEL pop up (Service DEF System, See Dealer)? If so what was the outcome. I did a search on the forum but couldn't find anything. Popped up on me today at 3,700 miles.

  2. #2
    RAM Platinum Member Captainmal's Avatar
    Join Date
    Dec 2013
    Location
    Sundance (Wimauma), Florida
    Posts
    7,451
    Member #
    185
    Vehicle
    '14 Ram 1500 Ecodiesel quad cab 4 x 4
    Liked
    3678 times
    If I remember correctly, there is a post on that issue here. Think it turned out to be an oxygen sensor.

    Search around. You are probably better with that computer stuff than me.

  3. #3
    RAM Regular sledogmilionair's Avatar
    Join Date
    Mar 2014
    Location
    Minnesota
    Posts
    338
    Member #
    424
    Vehicle
    2014 Ram 1500 Outdoorsman CC 4x4
    Liked
    49 times
    This happened to my wife's jeep GC Eco diesel and all they had to do is a flash update. Completely a software issue


    Sent from my iPhone using Tapatalk
    Soon to be former ecodiesel owner

  4. Remove Advertisements
    Ram1500Diesel.com
    Advertisements
     

  5. #4
    RAM Rookie Ramzees's Avatar
    Join Date
    Sep 2014
    Posts
    7
    Member #
    2701
    Liked
    3 times
    This happened to me twice the first time was at 1200 miles and was right around the time they came out with a flash update to change the sensitivity for the sensors in the exhaust system so dealer turned off CEL and performed that update. For the next 2400 miles no issues then the CEL popped on with the message service DEF system see dealer immediately. They found a stored code for a bad Nox sensor so they ordered up one and two weeks later when it came in they installed it and no more issues since I'm at 5010 miles now. My dealer is great put me in a loaner for the two weeks I waited on part to come in. Dealer noted that P/N on that sensor had changed which indicated an upgrade of some sort of that part.
    Captainmal likes this.

  6. #5
    RAM Platinum Member Captainmal's Avatar
    Join Date
    Dec 2013
    Location
    Sundance (Wimauma), Florida
    Posts
    7,451
    Member #
    185
    Vehicle
    '14 Ram 1500 Ecodiesel quad cab 4 x 4
    Liked
    3678 times
    Welcome Ramzees. Hope Cheddy is now more at ease.

  7. #6
    RAM Rookie WM12Ram's Avatar
    Join Date
    Sep 2014
    Posts
    11
    Member #
    2658
    Just wanted to jump in here. I've got about 1900 miles on my 2015 and I got the same light when I went out for lunch today.

    The dealer said that it would be Friday before I can get it in, but I'm hoping my sales guy can get it in early. I now see that it won't start in 200 miles. I'm hoping it is just a flash that needs to be done, but we'll see.

    Hope to know more tomorrow.

  8. #7
    RAM Platinum Member Captainmal's Avatar
    Join Date
    Dec 2013
    Location
    Sundance (Wimauma), Florida
    Posts
    7,451
    Member #
    185
    Vehicle
    '14 Ram 1500 Ecodiesel quad cab 4 x 4
    Liked
    3678 times
    Darn thing is thinking it's out of DEF. Or, maybe the DEF system quit injecting?

    Dealer will fix it.

  9. #8
    RAM Rookie WM12Ram's Avatar
    Join Date
    Sep 2014
    Posts
    11
    Member #
    2658
    The plot thickens a bit. The error finally cleared itself for New Years, and talking with my sales guy, he said that it may have been a fluke. Well, today, I was out driving for a bit, and after parking at a store and getting a few things, the bloody error came back again. So, it looks like it will see if my apt time slot is open tomorrow - hoping it is a quick fix. The DEF gage still says over 1/2 tank.

    I'm hoping it is a quick fix (i.e. firmware) or something similar rather than something major. I kind of like to be able to drive my own truck vs a loaner/rental. Especially since I've only had it less than a month.

    I'll post what they are able to find.

  10. #9
    RAM Sr Member Patty's Avatar
    Join Date
    Oct 2014
    Location
    NE Alberta, Canada
    Posts
    174
    Member #
    3079
    Vehicle
    2014 SLT, EcoDiesel, White, CC, 4x4, 3.55
    Liked
    42 times
    Quote Originally Posted by WM12Ram View Post
    The plot thickens a bit. The error finally cleared itself for New Years, and talking with my sales guy, he said that it may have been a fluke. Well, today, I was out driving for a bit, and after parking at a store and getting a few things, the bloody error came back again. So, it looks like it will see if my apt time slot is open tomorrow - hoping it is a quick fix. The DEF gage still says over 1/2 tank.

    I'm hoping it is a quick fix (i.e. firmware) or something similar rather than something major. I kind of like to be able to drive my own truck vs a loaner/rental. Especially since I've only had it less than a month.

    I'll post what they are able to find.
    Any update on the outcome of your repair? Just today my truck has a check engine light and the service DEF system - see dealer message on the EVIC. My truck is almost 7 months old with 19,300 KM (11,600 miles) on the clock.

  11. #10
    RAM Rookie WM12Ram's Avatar
    Join Date
    Sep 2014
    Posts
    11
    Member #
    2658
    The dealer was able to finish it on Saturday. What they ended up doing was a software/firmware update to the latest code. I've been reading in the forums that sometimes that this is the fix.
    I've driven it a bit since then, and it appears the issue was taken care of.

    I find that odd as it was mfg. at the very end of November or the first couple of days in December, but never got the latest update.

    Regardless, I hope that this is taken care of as the winter is here and the x4 is nice these days.

Page 1 of 6 123 ... LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Help! Service electronic braking system
    By Donks in forum RAM 1500 Diesel Mechanical
    Replies: 9
    Last Post: 02-05-2015, 06:01 PM
  2. Pre-Lube System
    By dmcelhannon in forum RAM 1500 Diesel General Discussion
    Replies: 11
    Last Post: 12-08-2014, 10:53 PM
  3. Navigation system and altitude
    By kcs129 in forum RAM 1500 Diesel General Discussion
    Replies: 3
    Last Post: 12-02-2014, 01:45 AM
  4. Security System
    By Spur in forum RAM 1500 Diesel General Discussion
    Replies: 2
    Last Post: 11-23-2014, 12:14 PM
  5. How the Exhaust System is Set Up.
    By Captainmal in forum RAM 1500 Diesel Mechanical
    Replies: 9
    Last Post: 04-21-2014, 02:02 PM

Search tags for this page

2015 ram fuel system needs repair reset message board
,
5 mph max service def system
,
def system needs service message dodge ram 2500
,
dodge ram 2015 service def system see dealer
,
ecodiesel ram service def system see dealer
,
how to reset def system on dodge
,

service def system see dealer

,
what causes check engine light to come on a 2016 ram service def system
Click on a term to search for related topics.