Service Tire Pressure System error on EVIC

Service Tire Pressure System error on EVIC

This is a discussion on Service Tire Pressure System error on EVIC within the RAM 1500 Diesel General Discussion forums, part of the RAM 1500 EcoDiesel Forum category; So multiple times a day my tire pressure system will show PSI on all 4 tires then i will get an error code "Service Tire ...

Results 1 to 3 of 3
  1. #1
    RAM Jr Member StrokerAce's Avatar
    Join Date
    Dec 2018
    Posts
    46
    Member #
    38514
    Liked
    22 times

    Service Tire Pressure System error on EVIC

    So multiple times a day my tire pressure system will show PSI on all 4 tires then i will get an error code "Service Tire Pressure System" 99 out of a 100 it will be just as it shows in the pic. Or either of the passenger side front or back tires, very rarely does the driver side not show PSI. The Tires are not the original so i believe this is the 2nd set. I bought the truck used about a month and a half ago. By the way this is one of the nicest riding trucks even cars i have ever been in, has 4 corner air ride. Here is what i think is happening, When the original owner changed tires he did not replace the battery powered sensors in the rims so the batteries are getting low and throwing a code. So the problem with that is that BOTH front and back sensors will go out at the same time, which tells me it is NOT the battery, is there a sensor other then the TPS in the rims that could be loose or going bad ?
    Attached Thumbnails Attached Thumbnails Service Tire Pressure System error on EVIC-evic.jpg   Service Tire Pressure System error on EVIC-suspension-error-codes.png  

  2. #2
    RAM Jr Member StrokerAce's Avatar
    Join Date
    Dec 2018
    Posts
    46
    Member #
    38514
    Liked
    22 times
    Anybody ?

  3. #3
    RAM Ninja DrivingZiggy's Avatar
    Join Date
    Jun 2014
    Location
    Lafayette, LA, USA
    Posts
    2,122
    Member #
    1513
    Vehicle
    2015 Big Horn EcoDiesel
    Liked
    1028 times
    Well, the only thing that I can add is that TWICE now--at 2 different tire shops--the technician broke the sensor.

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Trouble code Code po191 Fuel Rail Pressure Sensor Circuit Range error
    By ctenc001 in forum RAM 1500 Diesel General Discussion
    Replies: 11
    Last Post: 04-01-2019, 08:55 AM
  2. "Service Electronic Braking System" warning on EVIC
    By JGz Diesel in forum RAM 1500 Diesel General Discussion
    Replies: 1
    Last Post: 09-27-2018, 05:33 PM
  3. Service ParkSense Error Message in Cold Weather
    By roegs in forum RAM 1500 Diesel General Discussion
    Replies: 6
    Last Post: 12-26-2017, 11:13 AM
  4. Faulty TPM Causing Tire Gauge Error?!
    By Uncle Buck in forum RAM 1500 Diesel Wheels and Tires
    Replies: 19
    Last Post: 10-07-2016, 10:20 AM
  5. Tire Pressure monitor system change 30PSI Front 28PSI Rear
    By TCDiesel in forum RAM 1500 Diesel General Discussion
    Replies: 0
    Last Post: 10-02-2015, 07:21 PM