Guess it was my turn

Guess it was my turn

This is a discussion on Guess it was my turn within the RAM 1500 Diesel General Discussion forums, part of the RAM 1500 EcoDiesel Forum category; I've had 74k trouble free miles on my '15 ecodiesel. Best truck I've ever owned. Used to post on here but got nervous reading about ...

Page 1 of 3 123 LastLast
Results 1 to 10 of 22
Like Tree14Likes

Thread: Guess it was my turn

  1. #1
    RAM Jr Member vettnman's Avatar
    Join Date
    Nov 2014
    Posts
    51
    Member #
    3311
    Liked
    33 times

    Guess it was my turn

    I've had 74k trouble free miles on my '15 ecodiesel. Best truck I've ever owned. Used to post on here but got nervous reading about all the failures. I dont think mine is serious but who knows. Just had the aem update 2 weeks ago. Ever since then, the truck has been a dog. Major turbo lag. I've not been pleased with it. Started the truck this morning and it just felt different. Got 3 miles down the road and it just fell on its face. Wouldnt run but 20 mph and missing. Cut it off a few times and restarted it but still had no power. I finally got it up to 50 but that was the best I could do. Electronic throttle message was on screen. Called around trying to see if I could get it sent to Wilson ram dealership but nope Smithfield was closer. Well, this is what they told me. Said the air filter was dirty with bugs etc. That and the diagnostic cost $215. Truck still has warranty.. Now, maybe I'm just an average guy but theres no way a air filter caused that problem. Doing some reading, seems like either the map sensor is dirty or possibly a bad injector..Not a fan of the Smithfield dealership. Just hoping i can get my truck back
    markcfoster and dieseldoya like this.

  2. #2
    RAM Jr Member markcfoster's Avatar
    Join Date
    Dec 2018
    Posts
    38
    Member #
    38620
    Liked
    17 times
    Ya, I want to think this forum is causing a frenzy of unsubstantiated complaints but you’re not helping. Lol


    Sent from my iPhone using Tapatalk

  3. #3
    RAM Guru dieseldoya's Avatar
    Join Date
    Oct 2014
    Location
    Ontario Canada
    Posts
    1,177
    Member #
    2815
    Vehicle
    2015 Laramie LTD Crew Cab ED Black of course.
    Liked
    502 times
    Quote Originally Posted by vettnman View Post
    I've had 74k trouble free miles on my '15 ecodiesel. Best truck I've ever owned. Used to post on here but got nervous reading about all the failures. I dont think mine is serious but who knows. Just had the aem update 2 weeks ago. Ever since then, the truck has been a dog. Major turbo lag. I've not been pleased with it. Started the truck this morning and it just felt different. Got 3 miles down the road and it just fell on its face. Wouldnt run but 20 mph and missing. Cut it off a few times and restarted it but still had no power. I finally got it up to 50 but that was the best I could do. Electronic throttle message was on screen. Called around trying to see if I could get it sent to Wilson ram dealership but nope Smithfield was closer. Well, this is what they told me. Said the air filter was dirty with bugs etc. That and the diagnostic cost $215. Truck still has warranty.. Now, maybe I'm just an average guy but theres no way a air filter caused that problem. Doing some reading, seems like either the map sensor is dirty or possibly a bad injector..Not a fan of the Smithfield dealership. Just hoping i can get my truck back
    Same thing (kind of) happened to me but mine was plugged with snow/ice at -40F. Yes, it was a little chilly out.
    Limped it home that way for 300 miles too. Yes, it sucked but after feathering the throttle, I got her up to highway speeds.
    All covered under warranty, dealer said a sensor got damaged by the ice. Whatever...
    2015 Laramie ED 1500 Crew 4X4 Loaded. At 42000 kms now
    2003 GMC Duramax 2500 Crew 6.6 litre Diesel 4X4 Loaded
    1993 Chevrolet 1500 2 WD 6.2 litre Diesel Ext Cab Loaded
    1986 GMC 1500 2 WD 6.2 litre Diesel REG CAB Loaded




  4. Remove Advertisements
    Ram1500Diesel.com
    Advertisements
     

  5. #4
    RAM Guru DJL_57's Avatar
    Join Date
    Jan 2016
    Location
    Fresno, CA
    Posts
    1,015
    Member #
    7729
    Vehicle
    15 Tradesman QC 4x4 3.92
    Liked
    503 times
    Wait a minute. Your AEM was completed, which means you got a fresh warranty on diesel items and their labor. Yet you paid $215 for diagnosis? You got ripped off

    Sent from my SM-G892A using Tapatalk
    2015 RAM 1500 3.0L EcoDiesel/8HP70 4x4. QC 6'4' 140" WB. Factory options: Protection Group, Exterior Appearance Group, Trailer Tow Mirror and Brake Control Group, Popular Equipment Group, 3.92, Anti-Spin, UConnect 5.0, ParkView
    List of mods - DJL_57'S RAM

  6. #5
    RAM Ninja Perrysburg Dodgeboy's Avatar
    Join Date
    Jun 2014
    Location
    Ohio
    Posts
    2,051
    Member #
    1565
    Vehicle
    2015 1500 Laramie CC SWB GDE Eco-diesel 4X4
    Liked
    982 times
    Well have you ever changed the filter? Just asking, but $215 for an air filter is a bit extreme to me. How many hours did they charge you?
    2015 Ram Laramie Crew Cab, short box, 4X4, GDE Tune, western brown with canyon brown light frost beige W/BENCH SEAT, wheel to wheel bars, front windows tinted 15%, 8.4AN radio and more gadgets than I know what to do with!

  7. #6
    RAM Sr Member 3DHawkeye's Avatar
    Join Date
    Nov 2015
    Location
    Eastern Iowa
    Posts
    153
    Member #
    7326
    Vehicle
    2015 Ram 1500 Big Horn Crew Cab 4x4 with 3:55
    Liked
    30 times
    I also have a hard time believing that your air filter caused that much of a problem. You got hosed on diagnostic, good luck to you.


  8. #7
    RAM Jr Member vettnman's Avatar
    Join Date
    Nov 2014
    Posts
    51
    Member #
    3311
    Liked
    33 times
    So I have an update from the stealership. First though, maybe I'm wrong, but the air filter is part of the normal maintenance. I dont have a problem with that. The diagnostic unfortunately, from what I understand, is not covered under warranty. Yes, I have the fresh warranty but I also have my 5 year/100k warranty. Neither supposedly covers that. I had the filter changed awhile ago. Somewhere around the 40k mark. Now, I stopped by to chat with the service rep. They didnt touch the truck today because I told them yesterday to not worry about the air filter, I would change that. Well, apparently, that destroyed that flow chart they like to follow. Smdh. I asked if they cleared the codes. Answered no because the air filter hadnt been changed. So I went and bought them a air filter for the truck. I had asked them to clean the map sensor. I was told today that you cant really clean it????? I was under the impression that it tends to build up with soot and could cause the problem I had. Somebody answer that for me? I mentioned to her that the truck had started using coolant to the tune of about a half gallon every couple of months and had he checked the egr valve. Nope, and if that was the problem, it's not covered under warranty she thought. She wasnt sure on that but that's what she thought. I'm pretty sure I'm dealing with a bunch of clowns over there. I've not been impressed at all with this dealership which is why I tried to get it to Wilson. So, they now have a air filter and ge will continue his diagnostic tomorrow. I'm about ready to strangle somebody over there
    Captainmal and sourdo like this.

  9. #8
    RAM Jr Member vettnman's Avatar
    Join Date
    Nov 2014
    Posts
    51
    Member #
    3311
    Liked
    33 times
    So I just went over my extended warranty and yep, you guys are right. Diagnostic is covered u nder warranty. Good thing g I havent paid that yet. Also, egr IS covered u der the warranty as well. That dealership never knows what they're talking about
    TwoBobs, sourdo and 3DHawkeye like this.
    2015 Ram Laramie Ecodiesel 4wd crewcab
    Maximum Steel/Silver two tone
    Ordered 11-11-14

  10. #9
    RAM Professional biodiesel's Avatar
    Join Date
    Jul 2016
    Location
    Zuni Mountains, New Mexico
    Posts
    598
    Member #
    9554
    Vehicle
    2015 Ram Ecodiesel
    Liked
    215 times
    Quote Originally Posted by vettnman View Post
    I had asked them to clean the map sensor. I was told today that you cant really clean it????? I was under the impression that it tends to build up with soot and could cause the problem I had. Somebody answer that for me?
    I've had my MAP senor clogged to the point the truck detuned and I had to limp to the dealership. So yes, it can be a problem. I now change the MAP sensor every 20,000 miles just to be safe. And to answer your question, you and I can clean our MAP sensor but that's not the protocol for the dealership. They are more likely to replace it than to clean it.
    2015 3.0 Ecodiesel/Big Horn/1500/QCSB/4x4
    2016 Arctic Fox/Travel Trailer 22G/Onboard LP Cummins Onan Generator/160 Watt Solar Panel

  11. #10
    RAM Sr Member RAM259's Avatar
    Join Date
    Oct 2015
    Location
    ILL-summer / FL-winter
    Posts
    207
    Member #
    7097
    Vehicle
    2015 RAM ED
    Liked
    96 times
    I would be making sure that coolant problem gets fixed before it causes some serious damage.


    Sent from my iPhone using Tapatalk Pro
    biodiesel and 3DHawkeye like this.
    2015 CC 4X4 Tradesman

Page 1 of 3 123 LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •