2015 Replaced Water Pump Today

2015 Replaced Water Pump Today

This is a discussion on 2015 Replaced Water Pump Today within the RAM 1500 Diesel General Discussion forums, part of the RAM 1500 EcoDiesel Forum category; Well not all in one day had a short fall pretty quick into it. It’s not a terribly difficult job BUT you need to be ...

Results 1 to 7 of 7
Like Tree13Likes
  • 8 Post By Jeff Melber
  • 3 Post By r3gill
  • 1 Post By Kazimodo
  • 1 Post By r3gill

Thread: 2015 Replaced Water Pump Today

  1. #1
    RAM Rookie Jeff Melber's Avatar
    Join Date
    Sep 2016
    Location
    Lehighton, PA
    Posts
    20
    Member #
    12257
    Vehicle
    2015 Ecodiesel, tradesman
    Liked
    28 times

    2015 Replaced Water Pump Today

    Well not all in one day had a short fall pretty quick into it. It’s not a terribly difficult job BUT you need to be prepared with all the o-rings before you start. I’ve read posts where guys are replacing them in a few hours. I have no idea how they get this done in 2.5 hours if they do all of the following:

    Disconnect Battery

    1. Drain Coolant. My petcock wouldn’t work so I needed to undo a low hose fitting.
    2. Remove coolant reservoir.
    3. Remove Intercooler hoses. (Upper charge hose).
    4. Remove coolant hose at thermostat and pump. Pull toward passenger side and secure out of the way.
    5. Remove vacuum pump and stick in lower charge hose with some paper towel wadding.
    6. Remove vacuum pump bracket and pull AC lines to make some room (we’re talking an inch or MAYBE two - be somewhat gentle)
    7. Remove fuel injection pump front plastic cover to gain access to the Lower nut on fuel return line.
    8. Remove fuel line bracket on top of intake so you can flip the fuel return line around.
    9. Disconnect upper and lower fuel return line nuts and spin the line around so its outta da way.
    10. Remove the serpentine belt plastic cover (Yes there’s a cover over the serpentine belt)
    While were here I’ll note you CANNOT just replace the serpentine belt. You need to remove the cover AND all the crap that holds the vacuum pump.
    11. Remove serpentine belt.
    12. Remove serpentine belt tensioner.
    13. Remove serpentine belt tensioner bracket.

    You are now ready to actually start taking bolts out of the water pump.

    14. Remove plastic bypass tube. Be careful prying it out. I suggest you do most of the prying on the driver side.
    15. Loosen thermostat housing bolts. (Do it now so you don’t need to wrestle with it when it’s out - if you don’t have a vice) once the pump is off the truck you can swap over the housing and a new t-stat if you desire. Replace that O-Ring.
    16. Disconnect water temp sender.
    17. Pull the 6 bolts on the pump and pull it straight out. Mine was easy.

    At this point I suggest you remove ALL o-rings. There are 5 of them. The pump comes with gaskets IN THE PUMP HOUSING. NO O-rings. The gasket kits Mopar sells are only the gaskets in the pump - NO O-rings. You need to purchase them separately.

    Clean all the o-ring surfaces. Especially the female ones. I used a little Vaseline to lube the install.

    I fully believe you guys having problems later are a result of NOT replacing the O-ring on the inlet tube. That’s the one under the Intake plenum. Mine was in POOR shape (see pictures).

    My vacuum pump bracket didn’t fit too well on the reinstall and had to be massaged a little. I messed with this probably more than anything else. Maybe trying to pull the o-ring under the intake plenum. I didn’t get too aggressive because you can’t see what you’re doing and I was afraid to gall up the O-Ring surfaces. Plus there’s just no room for my booger hooks in there.

    Install is - well - run through the list backwards. That’s 34 steps at 5 minutes a step = 2.8 hours, but you ain’t getting a lot of those in 5 minutes. I’d say plan on 4 hours. Take your time. Don’t take any short cuts like yanking stuff out of the way. Don’t turn a nice little mechanical failure into an intermittent electrical problem.

    I got it together and no leaks but didn’t get it up to temp. Got a trip to Colorado planned and leaving on the 27th.

    O-Ring part numbers:

    68157217AA THERMOSTAT
    68211201AA BYPASS TUBE O-RING
    68258961AA BYPASS TUBE FLANGE GASKET (RED in color)
    5066884AA INLET TUBE UNDER INTAKE PLENUM
    68147586AA INLET TUBE AT REAR OF PUMP (FLANGED CONNECTION)

    I bought my pump from mopar online parts and the O-Rings at the dealership. The pump is two pieces and mine looks like it was leaking at the pump seam. Very slow leak for the last 60k miles truck has 150k on it now. I’m pretty certain it’s the pump housing that’s leaking and if it’s a fresh install and the O-Ring in the valley isn’t replaced I’m positive that sucker is leaking on you. But you’ll never know that on a warranty repair. It’s all just a bad pump - No lazy mechanics.

    Good Luck.

    2015 Replaced Water Pump Today-d1658cf7-88e0-44b2-8dd5-554781252f72.jpeg2015 Replaced Water Pump Today-4a2fec38-9d49-4a60-8163-4b949dbedb40.jpeg2015 Replaced Water Pump Today-97374ec4-3e45-4a81-97b0-db167b5c6181.jpeg
    Last edited by Jeff Melber; 08-14-2019 at 08:22 PM. Reason: Added mileage and information
    whitrock, 97hmcs, redsunBC and 5 others like this.

  2. #2
    RAM Regular r3gill's Avatar
    Join Date
    Aug 2016
    Location
    Vancouver Canada
    Posts
    399
    Member #
    10922
    Vehicle
    2015 Ram Ecodiesel St quad cab 2wd.
    Liked
    214 times
    Great write up. I will add to this on serpentine belt replacement.

    You dont need to remove all the crap uptop to replace the belt.
    Just remove the belt cover and remove bolts on the bracket holding the lines together. You can now push the bracket just enough to clear the old belt out and slide new one in.

    I was able to replace both my idlers and tensioner with new belt in half an hour this way..
    97hmcs, markcfoster and Mopar73340 like this.

  3. #3
    RAM Rookie Jeff Melber's Avatar
    Join Date
    Sep 2016
    Location
    Lehighton, PA
    Posts
    20
    Member #
    12257
    Vehicle
    2015 Ecodiesel, tradesman
    Liked
    28 times
    Thanks R3

    When I had it all apart and I had the tensioner in my hand and looking at the idlers I thought now is the time. I didn’t do it. They all “felt good”. How many miles did you have on it and were they giving you any warning?

    I’m not crazy about having just enough room to do anything. Anyway, our differences aside on how much room we need to change a belt I bet its not at all what you thought it was going to be when you started.

    The more I work on this new stuff the more I question owning one beyond the factory warranty.

    I wish I could buy a new truck with an Engine, Powertrain, and wiring delete option. Just pigtails at each of the lights :-)
    Last edited by Jeff Melber; 08-15-2019 at 05:41 AM. Reason: Added info

  4. Remove Advertisements
    Ram1500Diesel.com
    Advertisements
     

  5. #4
    RAM Jr Member damien256's Avatar
    Join Date
    Apr 2015
    Location
    CT
    Posts
    69
    Member #
    5438
    Vehicle
    2015 ED QC 4X4 6'4" bed 3.55 gears
    Liked
    43 times
    Quote Originally Posted by Jeff Melber View Post
    Well not all in one day had a short fall pretty quick into it. It’s not a terribly difficult job BUT you need to be prepared with all the o-rings before you start. I’ve read posts where guys are replacing them in a few hours. I have no idea how they get this done in 2.5 hours if they do all of the following:

    Disconnect Battery

    1. Drain Coolant. My petcock wouldn’t work so I needed to undo a low hose fitting.
    2. Remove coolant reservoir.
    3. Remove Intercooler hoses. (Upper charge hose).
    4. Remove coolant hose at thermostat and pump. Pull toward passenger side and secure out of the way.
    5. Remove vacuum pump and stick in lower charge hose with some paper towel wadding.
    6. Remove vacuum pump bracket and pull AC lines to make some room (we’re talking an inch or MAYBE two - be somewhat gentle)
    7. Remove fuel injection pump front plastic cover to gain access to the Lower nut on fuel return line.
    8. Remove fuel line bracket on top of intake so you can flip the fuel return line around.
    9. Disconnect upper and lower fuel return line nuts and spin the line around so its outta da way.
    10. Remove the serpentine belt plastic cover (Yes there’s a cover over the serpentine belt)
    While were here I’ll note you CANNOT just replace the serpentine belt. You need to remove the cover AND all the crap that holds the vacuum pump.
    11. Remove serpentine belt.
    12. Remove serpentine belt tensioner.
    13. Remove serpentine belt tensioner bracket.

    You are now ready to actually start taking bolts out of the water pump.

    14. Remove plastic bypass tube. Be careful prying it out. I suggest you do most of the prying on the driver side.
    15. Loosen thermostat housing bolts. (Do it now so you don’t need to wrestle with it when it’s out - if you don’t have a vice) once the pump is off the truck you can swap over the housing and a new t-stat if you desire. Replace that O-Ring.
    16. Disconnect water temp sender.
    17. Pull the 6 bolts on the pump and pull it straight out. Mine was easy.

    At this point I suggest you remove ALL o-rings. There are 5 of them. The pump comes with gaskets IN THE PUMP HOUSING. NO O-rings. The gasket kits Mopar sells are only the gaskets in the pump - NO O-rings. You need to purchase them separately.

    Clean all the o-ring surfaces. Especially the female ones. I used a little Vaseline to lube the install.

    I fully believe you guys having problems later are a result of NOT replacing the O-ring on the inlet tube. That’s the one under the Intake plenum. Mine was in POOR shape (see pictures).

    My vacuum pump bracket didn’t fit too well on the reinstall and had to be massaged a little. I messed with this probably more than anything else. Maybe trying to pull the o-ring under the intake plenum. I didn’t get too aggressive because you can’t see what you’re doing and I was afraid to gall up the O-Ring surfaces. Plus there’s just no room for my booger hooks in there.

    Install is - well - run through the list backwards. That’s 34 steps at 5 minutes a step = 2.8 hours, but you ain’t getting a lot of those in 5 minutes. I’d say plan on 4 hours. Take your time. Don’t take any short cuts like yanking stuff out of the way. Don’t turn a nice little mechanical failure into an intermittent electrical problem.

    I got it together and no leaks but didn’t get it up to temp. Got a trip to Colorado planned and leaving on the 27th.

    O-Ring part numbers:

    68157217AA THERMOSTAT
    68211201AA BYPASS TUBE O-RING
    68258961AA BYPASS TUBE FLANGE GASKET (RED in color)
    5066884AA INLET TUBE UNDER INTAKE PLENUM
    68147586AA INLET TUBE AT REAR OF PUMP (FLANGED CONNECTION)

    I bought my pump from mopar online parts and the O-Rings at the dealership. The pump is two pieces and mine looks like it was leaking at the pump seam. Very slow leak for the last 60k miles truck has 150k on it now. I’m pretty certain it’s the pump housing that’s leaking and if it’s a fresh install and the O-Ring in the valley isn’t replaced I’m positive that sucker is leaking on you. But you’ll never know that on a warranty repair. It’s all just a bad pump - No lazy mechanics.

    Good Luck.

    Click image for larger version. 

Name:	D1658CF7-88E0-44B2-8DD5-554781252F72.jpeg 
Views:	17 
Size:	1.67 MB 
ID:	81844Click image for larger version. 

Name:	4A2FEC38-9D49-4A60-8163-4B949DBEDB40.jpeg 
Views:	17 
Size:	2.14 MB 
ID:	81846Click image for larger version. 

Name:	97374EC4-3E45-4A81-97B0-DB167B5C6181.jpeg 
Views:	16 
Size:	1.38 MB 
ID:	81848
    Great write up, Thank You!! Wish I saw this before the dealer replaced mine under warranty. I had 92,000 on the ECO 2015, when I brought it in for repair. It had been weeping coolant for some time, I noticed a "coolant scent"first (around 50K miles, then the last straw was the puddles it started leaving in parking spots. I wanted to get repair done before the 100K warranty was up. Luckily, VERY LUCKILY, a brand new CDJR dealership opened up close by and they treated me like a rock star. Not that I am at all, but very surprised that they gave me a brandie new (3 miles) 2019 Ram 1500 hemi as a loaner. I kept it for the whole week the truck was in for repair. Obviously, if it was on my dime I would have been more assertive on repair time, but hey, 2019Hemi AND new tires, couldnt resist baking-em every stop sign......

    Thanks again for the informative write up, I will use this in the future. OH, FYI, the Service Manager told me FCA is having "failures" of the orings on a regular. He also said if I do this repair in the future to be very careful on reinstalling them.Not a good design for the backyard wrench, but isnt that the point of cars today??
    Peace,
    D

  6. #5
    RAM Jr Member PapaCap's Avatar
    Join Date
    Jun 2019
    Location
    Portland, OR
    Posts
    88
    Member #
    40660
    Vehicle
    2017 RAM 1500 EcoD Laramie Longhorn
    Liked
    25 times
    OP, sounds like you saved yourself a grand! Nicely done.
    2017 RAM 1500 Laramie Longhorn, GDE (w/engine braking), Diamondback bed cover & Cross Bin 8 tool tray, HID low beams (55 watt, 6K), LED high beams (both by GTR Lighting), OEM nerf bars, Geno’s billet locking fuel & DEF caps, Thule rooftop rack tracks with Yakima 60” Aero Jetstream crossbars & Thule Hullavator, Garmin dashcam, Escort radar detector, AVS hood shield & window deflectors, Dee Zee heavyweight bed mat, Dee Zee tailgate assist.

  7. #6
    RAM Bronze Member Kazimodo's Avatar
    Join Date
    Oct 2015
    Location
    Montreal Quebec Canada
    Posts
    2,806
    Member #
    6985
    Vehicle
    2015 Big Horn CC 5.7' 3.55
    Liked
    1332 times
    great step by step , copied to my water pump file
    ..
    i like the work table image .
    .
    nice complement to this other thread :https://www.ram1500diesel.com/forum/...ump-today.html

    lots of images thanks to Barboots and of course OP Teameno86

    (( all water pump related for easy additional info )).
    markcfoster likes this.

  8. #7
    RAM Regular r3gill's Avatar
    Join Date
    Aug 2016
    Location
    Vancouver Canada
    Posts
    399
    Member #
    10922
    Vehicle
    2015 Ram Ecodiesel St quad cab 2wd.
    Liked
    214 times
    Quote Originally Posted by Jeff Melber View Post
    Thanks R3

    When I had it all apart and I had the tensioner in my hand and looking at the idlers I thought now is the time. I didn’t do it. They all “felt good”. How many miles did you have on it and were they giving you any warning?

    I’m not crazy about having just enough room to do anything. Anyway, our differences aside on how much room we need to change a belt I bet its not at all what you thought it was going to be when you started.

    The more I work on this new stuff the more I question owning one beyond the factory warranty.

    I wish I could buy a new truck with an Engine, Powertrain, and wiring delete option. Just pigtails at each of the lights :-)
    Lol we all want those good ol trucks with simple basic stuff.. But at the same time wont give up new ones..

    Regarding the idlers my belt let go while towing on Interstate 5 in washington. 70k miles. Now why the belt failed no idea. So I just replaced the belt at a truck stop.. Came home and replaced both idlers and tensioner for peace of mind. Tensioner pulley had a hard spot while turning and one of the idlers were making a little noise while spining. But cant say they actually made the belt fail. Its a pain when you break down in holidays with something this basic.

    Before it failed I was chasing a ticking sound comming from the front of engine every cold start and then the noise would go away after the engine was warm. Couldnt figure it out untill the belt totally snapped. Havent had this ticking noise after the belt/tensioner/idler replacement.
    markcfoster likes this.

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •