P0234 and SETC Issues that i cannot figure out.

P0234 and SETC Issues that i cannot figure out.

This is a discussion on P0234 and SETC Issues that i cannot figure out. within the RAM 1500 Diesel General Discussion forums, part of the RAM 1500 EcoDiesel Forum category; Hello everyone. I apologize about the formatting in advance, this may be a long post. I purchased my 2015 ED longhorn the beginning of may, ...

Results 1 to 7 of 7
Like Tree3Likes
  • 2 Post By DrivingZiggy
  • 1 Post By sourdo

Thread: P0234 and SETC Issues that i cannot figure out.

  1. #1
    RAM Rookie rayscordova's Avatar
    Join Date
    Jun 2019
    Posts
    5
    Member #
    40744

    P0234 and SETC Issues that i cannot figure out.

    Hello everyone.

    I apologize about the formatting in advance, this may be a long post.

    I purchased my 2015 ED longhorn the beginning of may, 36000 miles on the OD. currently sitting at 42000. I Had the truck for a month before I purchased the GDE hot tune and tranny tune.

    June
    My issue started while towing a travel trailer from CO to NM about 300 miles round trip. truck did perfectly until about 30 miles from home on the return trip I had the Service electronic throttle control and CEL display and truck when into "limp mode" took a couple of restarts and the SETC and CEL stood on. had to have my father come pick up the wife, kids and TT with his truck. Waited for about 30 mins and restarted truck again and SETC code went away and I was able to drive fine home. I then took it to the dealer next day they and the reset code and sent me on my way. auto zone read said P0234. GDE Hot tune was installed for dealer visit. Tranny tune was flashed back to original

    July
    everything was fine we did multiple trips in July up and down the CO mountains . End of July comes around and my father borrows my truck to take the family to a Rockies game. about 30 mins out of town my father calls and lets me know that the truck threw the same codes as last time. drove his truck to swap vehicles. and sent them on their way. I get the truck and restart SETC goes away but CEL stays on. Head to dealer to make them aware and see what is going on. they have it for a day and cannot recreate the issue. Dealer said that I missed part of the recall reflashed U07 update to ecu because they say it did not take the first time. (I can still drive my truck in reverse with no seatbelt and door open) said that fixed the issue and set me on my way. Auto Zone read said P0234 GDE Hot tune was installed for dealer visit. Tranny tune was flashed back to original

    August
    No issues.

    September
    we head to the mountain west of Denver for some gambling fun with friends. Roughly 300 miles round trip. I70 is a pretty treacherous road with consistent 6.5% grades up and down. about 15 (90 Miles from Home) miles out of Black hawk getting onto the highway on an on ram I notice the truck starting to stutter (seems like this happens before it throws the codes) release throttle gently and it gets back to normal. 2 miles down the road overtaking a semi the truck throws the CEL SETC codes again loose all power and limp mode. pull over restart. No SETC Cel still on. get back on the road and drive the truck gently. 2 miles again it throws the code. this time I was a little bit harder on the gas to get me up the grade. pull over and restart truck. I drive the truck gently to our destination and did not get SETC but CEL stays on. truck stayed parked overnight. the next morning we start our trip down the mountain to Denver truck wanted to start a regen but stood at 80% when we reached our destination 30 miles away. ( all down hill so regen did not complete, im guessing because engine was not under power CEL is on the whole time and did not get an SETC coming down the mountain) from Denver to home CEL stays on, and multiple times I get on the gas an it was perfect no stuttering and no SETC code. I stop at auto zone and P0234 was the code the truck had stored (He accidentally cleared code).. I head to dealer and let them know what happened this will now be the third time I am at the dealer for the same issue. Im not happy with this dealer btw. they say they will get to it in two weeks. have a conversation with service writer and he says that I don't know what I am talking about. GDE Hot tune was installed for dealer visit. Tranny tune was flashed back to original. he also says that he see in the dealer scan tool that there are multipole TCU disconnects and asked if I have done anything electronically to the truck.( most likely to tranny tune being flashed to original)

    Today
    I Went to the dealer the next city over and they said that they have many of the clients from the hometown dealer come here due to service issued and general knowledge. The were understanding about my Situation and much more helpful. they said because the code is not there they can try to keep the truck for a few days and try to recreate the problem. Knowing the truck It Is inconsistent when It throws the code I say I will get more drive time if I have the truck then if I left it at the dealer. they say to bring in when CEL is active again.

    Im hoping somebody here has had this issue and has had a fix or somebody can tell me what I need to do next. Im Starting to pull my hair out.

    truck is under MGF powertrain warranty. and I have a secondary warranty from when I purchased the truck from another dealer.

    AEM has been completed

    I do not believe that the GDE Tune has been overridden. I Can still start my cruise control at 15 MPH

    Please ask any questions that I did not answer to help you help me.

    Regards

    Ray
    Last edited by rayscordova; 09-10-2019 at 09:32 PM.

  2. #2
    RAM Ninja DrivingZiggy's Avatar
    Join Date
    Jun 2014
    Location
    Lafayette, LA, USA
    Posts
    2,184
    Member #
    1513
    Vehicle
    2015 Big Horn EcoDiesel
    Liked
    1065 times
    My truck used to throw the SETC code occasionally. Until I got a new battery. Yes, it's true! First it would occasionally throw the code. And every once in a while when attempting to start the truck, it just wouldn't do anything. Then one day it wouldn't come back from not doing anything. Went and got a new battery and everything has been peachy since.

    So, if you don't have a new battery go out and spend a $couple hundred and it may just solve your problem. I recommend buying online from Batteries + and then picking it up at their store to get that discount.
    Novanorm and sourdo like this.

  3. #3
    RAM Professional sourdo's Avatar
    Join Date
    Apr 2018
    Location
    Palmer, Alaska
    Posts
    676
    Member #
    35289
    Vehicle
    2017 Tradesman QC 4x4 3.0 Ecodiesel 3.55 Axle
    Liked
    461 times
    Quote Originally Posted by DrivingZiggy View Post
    My truck used to throw the SETC code occasionally. Until I got a new battery. Yes, it's true! First it would occasionally throw the code. And every once in a while when attempting to start the truck, it just wouldn't do anything. Then one day it wouldn't come back from not doing anything. Went and got a new battery and everything has been peachy since.

    So, if you don't have a new battery go out and spend a $couple hundred and it may just solve your problem. I recommend buying online from Batteries + and then picking it up at their store to get that discount.
    Ziggy, it's the little stuff that stumps the "experts".

    I never would of thought to replace the battery either. It's these little tips that make this forum priceless!
    DrivingZiggy likes this.
    Cheers
    sourdo

  4. Remove Advertisements
    Ram1500Diesel.com
    Advertisements
     

  5. #4
    RAM Jr Member AOFA's Avatar
    Join Date
    Dec 2014
    Posts
    82
    Member #
    3777
    Vehicle
    2018 Bighorn Black Edition Ecodiesel, 2.5” level
    Liked
    40 times
    Rays
    Sounds very similar to my issue. But I am only getting the codes while towing. Hard to think that would be the battery, unless someone knows something I don’t?
    My codes appear when moderately accelerating, or when the truck down shifts up a grade. Nothing to harsh though... I’ve towed and pushed it way harder than when these codes have appeared.. 😕

  6. #5
    RAM Ninja shaggn85's Avatar
    Join Date
    Aug 2015
    Posts
    2,166
    Member #
    6602
    Vehicle
    2015 Dodge Ram 1500 Laramie EcoDiesel
    Liked
    1092 times
    What is setc?

  7. #6
    RAM Diamond Member Captainmal's Avatar
    Join Date
    Dec 2013
    Location
    Sundance (Wimauma), Florida
    Posts
    12,207
    Member #
    185
    Vehicle
    '19 Ram Cummins
    Liked
    6822 times
    To add to that you may also want to check that connector under the drivers' side of the frame. That can shake around as can loose grounds on major connections, like the battery.

    Nuts. That's where stuff like this can drive you.
    If you wrestle with a pig you'll both get dirty and the pig loves it. .

  8. #7
    RAM Rookie rayscordova's Avatar
    Join Date
    Jun 2019
    Posts
    5
    Member #
    40744
    @AOFA

    the first time my truck started doing it I was towing a TT. Now i get the code without a TT. When it does throw the code its the exact way you explained it. Sometimes it's fine when driving hard and other times it throws the code.

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Tags for this Thread