RAM 1500 Diesel Forum banner

1 - 20 of 78 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Just got a service engine light on my Eco. I put a code reader on it and its throwing code P026C. I found some sketchy info on the net that says Fuel Injection Quantity- quantity lower than expected. Last oil change at 11500 I changed the fuel filter I know have 19000 on it. Has anyone ran into this? Is this possibly a fuel filter change or injector issues? Thanks in advanced.
 

·
Registered
Joined
·
487 Posts
You can attempt to clear the code and see if it comes back. If so, then there are (obviously) other complications. Possibly bad fuel? Since it says "quantity", not quality, it could be a sensor for the EGR, TPS, or the injection pump itself.
I think first try to clear it.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
You can attempt to clear the code and see if it comes back. If so, then there are (obviously) other complications. Possibly bad fuel? Since it says "quantity", not quality, it could be a sensor for the EGR, TPS, or the injection pump itself.
I think first try to clear it.
I cleared it, came back with about 15 minutes of driving.
 

·
Registered
Joined
·
3,402 Posts
I would replace the fuel filter, it's cheap and the process of elimination that you can do yourself very easily and not get a bill over 100 dollars from a dealership and when you start your truck stand next to the fuel tank and listen for a loud whining noise, when a lift pump goes bad folks usually hear it whining first .
BTW I read your other post about leaves in the air cleaner intake causing codes , Thanks for sharing :)
 

·
Registered
Joined
·
10 Posts
Discussion Starter #9
I would replace the fuel filter, it's cheap and the process of elimination that you can do yourself very easily and not get a bill over 100 dollars from a dealership and when you start your truck stand next to the fuel tank and listen for a loud whining noise, when a lift pump goes bad folks usually hear it whining first .
BTW I read your other post about leaves in the air cleaner intake causing codes , Thanks for sharing :)
Thank you, I'll try a filter and listen for the pump.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #10
Hey guys here is a follow up so far. After a 2 week stent of my truck at the dealership, first attempt for a fix was a bust. They replaced the injector pump and a couple fuel lines. Got it back and within 100 miles the code came back, its at the dealership again, see what happens this time.
 

·
Registered
Joined
·
15 Posts
I have the same problem! Mine started about a month ago..truck has always ran fine..i did an oil change and fuel filter change, also added in some diesel clean. Mine seems to come and go with the cold weather. Im in oklahoma and it can be 65 one day then be in the 30's the next... my CEL came back on last thursday and is still on today. Im taking it in saturday to stealership to see what they allow, i will let u guys know

Sent from my SAMSUNG-SM-G891A using Tapatalk
 

·
Registered
Joined
·
246 Posts
You got further than I did Chuck. I had a P026C code a couple of days before Christmas. I reset it with my Edge CTS but it came back on last Wed (18 Jan). I got it into the dealer on Friday, 20 Jan. They ran diagnostics and told me my air filter was dirty, that they had to replace it as the first step in their trouble-shooting procedure (the air filter was 6 months old with about 14k miles on it). So, between the charge for diagnostics, the air filter, and the rental car, I spent about $210. They emphasized I may well get this code again and if I do, they'll try something else. Hopefully, they figure out it's something covered under my extended warranty so I'm not out of pocket every time they look at the truck.

Dave

Hey guys here is a follow up so far. After a 2 week stent of my truck at the dealership, first attempt for a fix was a bust. They replaced the injector pump and a couple fuel lines. Got it back and within 100 miles the code came back, its at the dealership again, see what happens this time.
 

·
Registered
Joined
·
575 Posts
I have a 2014. I just got a check engine light this afternoon. Plugging my code scanner I get:

P026C

and a

P1D30

from a historic fault log. What ever that means.

I tried to reset the check engine light and clear the codes. No luck.

A few days ago, I changed my fuel filter and replaced it with the OEM filter from Mopar. No leaks.

57K miles.

Any ideas?
 

·
Registered
Joined
·
575 Posts
Apparently, there is some type of delay before the check engine light goes off after clearing the codes with my reader and torque pro. This morning the check engine light was off and up until now at least, it remains off.

I will ping this thread if it comes back on for the same reason.
 
  • Like
Reactions: 97hmcs

·
Registered
Joined
·
575 Posts
P1D30 code was thrown again this evening. Have not seen that code again since the last posting at the end of March. I had torque pro clear it. I suspect the CEL will be gone sometime tomorrow.
 

·
Registered
Joined
·
2,379 Posts
P1D30 code was thrown again this evening. Have not seen that code again since the last posting at the end of March. I had torque pro clear it. I suspect the CEL will be gone sometime tomorrow.
P130D is "oil Viscosity too low". Its usually thrown if you forget to reset your oil life monitor... do you do your own oil changes? Check the Oil life monitor. Once it's set, Torque won't reset it. you need the dealer to clear it.

As far as the P026C, your dealer is being a moron (as usual). That code is not a fuel pressure code. Its an injection quantity. You have a clogged/defective injector. Given the low mileage, i would suspect a defective injector.
 

·
Registered
Joined
·
575 Posts
P130D is "oil Viscosity too low". Its usually thrown if you forget to reset your oil life monitor... do you do your own oil changes? Check the Oil life monitor. Once it's set, Torque won't reset it. you need the dealer to clear it.

As far as the P026C, your dealer is being a moron (as usual). That code is not a fuel pressure code. Its an injection quantity. You have a clogged/defective injector. Given the low mileage, i would suspect a defective injector.
No my oil changes are done at a Dealership. I have used about 25% of oil life monitor since the last change.
 

·
Registered
Joined
·
575 Posts
I just turned 60 k miles. If i need a new injector(s) are they covered under the standard 100 k miles powertrain warranty?
 

·
Registered
Joined
·
2,069 Posts
You got further than I did Chuck. I had a P026C code a couple of days before Christmas. I reset it with my Edge CTS but it came back on last Wed (18 Jan). I got it into the dealer on Friday, 20 Jan. They ran diagnostics and told me my air filter was dirty, that they had to replace it as the first step in their trouble-shooting procedure (the air filter was 6 months old with about 14k miles on it). So, between the charge for diagnostics, the air filter, and the rental car, I spent about $210. They emphasized I may well get this code again and if I do, they'll try something else. Hopefully, they figure out it's something covered under my extended warranty so I'm not out of pocket every time they look at the truck.

Dave
If you do not have over 100,000 miles on the truck there should be NO CHARGE except for the filter! Do you have the FCA extended warranty? If you do the rental should also have been covered as well! Something sure doesn't sound right here.
 
1 - 20 of 78 Posts
Top