RAM 1500 Diesel Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Good morning. My name is Angela and I bought my 2016 Eco Diesel new and am having trouble with a wheel hub bearing. I was alerted to the issue when an ABS and trailer brake sensor came on so I took the truck to a Dodge dealership to check it out. They told me the sensor was triggered due to a wheel speed sensor being bad. They replaced the wheel speed sensor but that didn't stop the ABS and trailer brake sensor from being triggered. I took the truck back in and was told it's a faulty wheel hub bearing so they attempted to replaced that on Friday (8/23/19) but they called me and said the part didn't fit. I now have a Check Engine sensor on. I dropped the truck off this morning to the dealer. The truck has 90k miles on it and all maintenance is up to date.
I'm scheduled to drive from Arizona to Missouri this Thursday towing a medium sized U-Haul trailer so whatever help/advice I can get, would be much appreciated.
 

·
Registered
Joined
·
385 Posts
It would be very helpful to know the actual codes the computer is storing. Maybe the service adviser can tell you that?

Have you heard anything further from the dealer yet? Seems they are fishing for an answer. My cynical side says they thought a new bearing would fix the issue and when it didnt they told you it didnt fit because they don't know the real answer. There is no way they don't have the proper bearing in stock for a RAM 1500...
 
1 - 2 of 2 Posts
Top