RAM 1500 Diesel Forum banner

21 - 33 of 33 Posts

·
Registered
Joined
·
4,621 Posts
so actuator is on the truck .....
did you add a little stopper on the actuator like the guy did in the video in post # 4 ??
that would mean all is well with actuator , and shutters could go back in if desired , or stay off .
..
in the video I see the guy moved the lever on actuator one notch in one direction before putting it back together ,
may be a necessary step to get the thing to move both ways , maybe when it is not moved it does not get
some thing needed to get it to come back ,, ??
 

·
Registered
Joined
·
241 Posts
Discussion Starter #22
I did not add the stopper

The check engine light has NOT turned back on

When I looked on the OBD fusion app at the monitors the cel lit up but I realized late yesterday it was not on when running

The eBay seller has not shipped the actuator as they can not find it

If we do not have to much rain today I’ll reinstall the AGS and see what happens

Red


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
241 Posts
Discussion Starter #23
Pulled the grill and watched the actuator move in both directions

Reinstalled the shutters and all is well

Not sure what I did but it’s working no CEL

Still shocked that the CEL disappeared when the shutters were in the shop on the floor?

Thank you

Red


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
241 Posts
Discussion Starter #24
Quick follow up

Monitors are not ready for emissions

Shows no permanent or pending code but I still see the U0284 but no CEL?

TY

Red


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
4,621 Posts
some codes kept in memory of monitors ,
I have a code stored in my Edge monitor about the control knobs of the cruise control acting up ,
I never had a CEL on the dash for it , but definitely remember having to press buttons more than once to activate cruise control
I don't worry about the stored code , there to give clues for later use I guess .
..
no CEL on dash is nice , good job cleaning the filthy actuator ...
 

·
Registered
Joined
·
241 Posts
Discussion Starter #28
So this fixed itself for a few days but cel popped back same code U0284.

I replaced the whole AGS set up and still have the cel.

I realize I’m just a parts changer but wtf that’s probably all the dealer would do?

Frustrated

Thank you

Red


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
241 Posts
Discussion Starter #29
I may be paranoid as the CEL is on but there is no stored codes just pending and permanent.

I’ll put some miles on it and see what happens.

TY
Red


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
4,621 Posts
a search with Google took me to another site ,,, where " YOU " were discussing the same subject ,
same username on other site , that's how I know it was you , well that did not help .....
..
maybe one of those codes that need a certain number of start cycles to disappear ..
 

·
Registered
Joined
·
241 Posts
Discussion Starter #31
Check engine light is now off.

Was at the dealership for recalls and they troubleshot it and came back with a broken wire in the harness.

$190 and supposedly fixed

We will see

Red


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
4,621 Posts
a broken wire in the harness ,,,
how many hours would it take for a regular guy wrenching on his own truck to find this ... an eternity if you ask me ...
good call having them find the trouble this time , congrats .
 
21 - 33 of 33 Posts
Top