RAM 1500 Diesel Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Has anyone hooked up an auxiliary brake controller? I hooked one up and my rv does not seem to be responding to it. A friend was told that most after marker installers could not get them to function either. DO you think I need to have dealership activate this through the computer? Any suggestions would be appreciated.
 

·
Registered
Joined
·
827 Posts
It sounds like you set up an aftermarket unit, not the OEM unit. The truck's computer doesn't need to be aware of an aftermarket unit, so if it's not working then something's wrong. Take it to a place that deals with trailers and RV's, they'll figure it out. The truck's computer will need to be flashed if you installed the OEM unit....which is what I'd recommend. I tow a lot. The dealer put in the OEM brake controller for $320. An aftermarket unit would cost that much if you had someone else install it. The OEM unit is a very elegant solution, being tied into the cluster and Nav system and all.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
I did install it myself. I have installed many over the years. I even purchased the wire unit for dodge and plugged right into the four prong connector. Being discussing with the wife to step up to factory unit and connect to both the 10 prong and 4 prong connectors. Then to the dealership.

Thanks for the help
 

·
Registered
Joined
·
1,518 Posts
I had a buddy just get a Sport, and the aftermarket unit wouldn't work properly. It seems like the controller plug is still controlled via the ECU. SO... to get it to work, we just tapped the wires. (like in the old days) The power, ground, and the power back to the trailer plug is OK. BUT, we tapped the break switch wire for the controller.
 

·
Registered
Joined
·
211 Posts
In 2013 Ram changed the electrical brake system and the aftermarket controllers will not function with the new system. The braking sensing circuit is very low power and the regular crop of controllers won't trigger from the low power circuit.
 

·
Registered
Joined
·
30 Posts
I had one installed you need a curt wiring harness with two plugs going to the truck. Tekonsha harness withe One plug with four prongs will not work. Made my trucks alarm go off . There is a single prong plug and three prong plug on the curt harness.
 
1 - 6 of 6 Posts
Top