RAM 1500 Diesel Forum banner
21 - 24 of 24 Posts

·
Registered
Joined
·
192 Posts
I had battery issues with mine the first month I had it. 22 Bighorn. Turned out to be a two things. A ground cable not bolted down. I found the nut taped to a wiring harness then searched out where it was supposed to go. And the cable connector to the ECU was not properly seated. I fixed those things and the battery problem went away.
 

·
Registered
2015 Ram 1500 Ecodiesel Big Horn Granite Crystal 4x4 CC 6'4" box
Joined
·
1,051 Posts
I had battery issues with mine the first month I had it. 22 Bighorn. Turned out to be a two things. A ground cable not bolted down. I found the nut taped to a wiring harness then searched out where it was supposed to go. And the cable connector to the ECU was not properly seated. I fixed those things and the battery problem went away.
It was probably a Monday or Friday truck.
 

·
Registered
Joined
·
3 Posts
I had battery issues with mine the first month I had it. 22 Bighorn. Turned out to be a two things. A ground cable not bolted down. I found the nut taped to a wiring harness then searched out where it was supposed to go. And the cable connector to the ECU was not properly seated. I fixed those things and the battery problem went away.
Same message on my 22 Laramie from new to now -with only 300 miles. I have not even had it a full week and so far 2 days of no start where a jump is required. Dealer could not find an issue after pulling the codes. they said a software update is being pushed out - actually on November 25th and can take up to a month for the truck to grab it. I asked why they can't update it while they have it and they said not possible. what? they told me I could leave my truck for the rest of the week and they would look for a short or ground issue...but maybe the software that is floating in the sky somewhere will take care of it. Rather than leaving a new truck sitting in their back service lot, I brought it home. I am going to call tomorrow and see if Ram does indeed care. This is my 3rd 5th generation Eco diesel, the other 2 were flawless.
 

·
Registered
2019 RAM 1500 Classic Tradesman 4X2 EcoDiesel
Joined
·
764 Posts
Discussion Starter · #24 ·
Same message on my 22 Laramie from new to now -with only 300 miles. I have not even had it a full week and so far 2 days of no start where a jump is required. Dealer could not find an issue after pulling the codes. they said a software update is being pushed out - actually on November 25th and can take up to a month for the truck to grab it. I asked why they can't update it while they have it and they said not possible. what? they told me I could leave my truck for the rest of the week and they would look for a short or ground issue...but maybe the software that is floating in the sky somewhere will take care of it. Rather than leaving a new truck sitting in their back service lot, I brought it home. I am going to call tomorrow and see if Ram does indeed care. This is my 3rd 5th generation Eco diesel, the other 2 were flawless.
Is that mythical update the Uconnect update others have referred to?
 
21 - 24 of 24 Posts
Top