RAM 1500 Diesel Forum banner

21 - 34 of 34 Posts

·
Administrator
Joined
·
8,388 Posts
It's still possible to have originated in the new radiator even though you rinsed it. I'm leaning on that being the case.
 

·
Registered
Joined
·
102 Posts
Discussion Starter #22
That would be a possibility but the contamination was present before I changed the radiator.
 

·
Vendor
Joined
·
1,132 Posts
Pressure test the cooling system. We have seen higher mileage engines get head gasket leaks. The gasket actually deforms the aluminum head over time and the the head bolts will lose torque and spring a leak.
 

·
Registered
Joined
·
284 Posts
You can also smell the Antifreeze in the expansion tank and see if it smells like diesel exhaust gas. This is the first thing I do when I am suspecting a blown head gasket.
 

·
Administrator
Joined
·
8,388 Posts
That would be a possibility but the contamination was present before I changed the radiator.
You can also smell the Antifreeze in the expansion tank and see if it smells like diesel exhaust. This is the first thing I do when I am suspecting a blown head gasket.
Did't know it was pre-existing. Smell exhaust? I'm back to head gasket. Sorry to hear.
 

·
Registered
Joined
·
102 Posts
Discussion Starter #27
Everything is happening at once.
The truck is also pushing coolant out of the overflow tube.I replaced the reservoir cap hoping that would fix that problem but no luck.
Parked the truck at the park n ride this morning ,this evening popped the hood to check coolant level, removed the reservoir cap and there was still enough pressure in the system that it pushed coolant out of the reservoir.
So, I stuck the overflow tube in a 20oz water bottle, went for a ten minute drive and when I got back home the water bottle was full of coolant.
Thinking that I should replace the thermostat now?
Other than the problems listed the truck still starts and runs as always. l guess the question is for how much longer.
 

·
Registered
Joined
·
284 Posts
Everything is happening at once.
The truck is also pushing coolant out of the overflow tube.I replaced the reservoir cap hoping that would fix that problem but no luck.
Parked the truck at the park n ride this morning ,this evening popped the hood to check coolant level, removed the reservoir cap and there was still enough pressure in the system that it pushed coolant out of the reservoir.
So, I stuck the overflow tube in a 20oz water bottle, went for a ten minute drive and when I got back home the water bottle was full of coolant.
Thinking that I should replace the thermostat now?
Other than the problems listed the truck still starts and runs as always. l guess the question is for how much longer.
You got a bad head gasket, exhaust gas is pressurizing you coolant system and pushing coolant out. Did you smell the coolant????

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
102 Posts
Discussion Starter #29
That makes perfect sense. Will give it the smell test today. I bet it will smell like rotten eggs. Haha
 

·
Registered
Joined
·
1,190 Posts
Unfortunately I agree with the head gasket, exhaust and/or combustion chamber pressure pushing coolant out.

Do all of the suggested diagnostics, you need to nip this in the bud before you get A/F into your crankcase and do any bearing damage. :eek:
 

·
Registered
Joined
·
8 Posts
Exact same problem I am having.
Everything is happening at once.
The truck is also pushing coolant out of the overflow tube.I replaced the reservoir cap hoping that would fix that problem but no luck.
Parked the truck at the park n ride this morning ,this evening popped the hood to check coolant level, removed the reservoir cap and there was still enough pressure in the system that it pushed coolant out of the reservoir.
So, I stuck the overflow tube in a 20oz water bottle, went for a ten minute drive and when I got back home the water bottle was full of coolant.
Thinking that I should replace the thermostat now?
Other than the problems listed the truck still starts and runs as always. l guess the question is for how much longer.
Did it end up being the head gasket? I am having the exact same problem.
 

·
Registered
Joined
·
1 Posts
Ditto Cory4777…RAMNIT, would love to know if you identified the problem. I've been struggling with the exact issues. EGR also deleted can't keep coolant in the thing.
 
21 - 34 of 34 Posts
Top