RAM 1500 Diesel Forum banner
1 - 20 of 36 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi Everybody,

Yesterday i have finally picked up my truck and today took it on it's maiden voyage. About 100Kms into the trip while cruising on the hwy at about 90kms/hr the cabin started filling up with a burnt smoke. Pulled over, popped the hood and I've noticed a light smoke (almost a haze) coming from around the air filter; it was smelling like electric burn. Check around, felt all electrical harnesses in the are but nothing jumped out at me. After a while the smoke and the smell went away but I am wondering what it might have been. I'll be checking with the service department tomorrow.
At first I thought maybe it was the exhaust re-gen but haven't seen any messages on the EVIC and only had 100Kms on board. Any ideas? Could have been the re-gen getting hot and burning whatever residual grease might have been left on it during manufacturing and assembly?

Thanks,
Chris
 

·
Registered
Joined
·
940 Posts
No idea. Mine had a slight burn smell so I took it for a rip...pushed it a bit and there was no more smell. I think it was just everything settling in.
 

·
Registered
Joined
·
200 Posts
I got mine last monday, drove it 1 hour and 20 minutes home from the dealership and had the same smell. I believe it was just the engine heating up to operating temperature for the first time and haven't had any problems or odd smells since.
 

·
Registered
Joined
·
213 Posts
The engine and components are covered in a lite coating to ward off rust during storage. The coating burning off is what you are smelling.
 

·
Registered
Joined
·
1,518 Posts
It' probably just burn off. BUT... there has been 2 cases (That I've heard of) that the bolts on the back of the EGR were loose.

I'd say to give it another day or 2... and then see if it's still smoking..


As an FYI... my truck, on the second day was making my eyes water, and I had to drive with the windows down. All "Burn" odor was gone within 500 mi. (about a week)
 

·
Registered
Joined
·
1,337 Posts
I had that burn smell for probably about 1000km...m it's just the factory oils/waxes and greases burning off... first time I shut my truck off white hazy smoke just like you described wafted out from under my hood.
It will go away
 

·
Registered
Joined
·
4 Posts
I had burnt smell on 2nd day... Just drove it and the smell went away. I would assume it was burning in, or burning off packaging material or oils.
 

·
Registered
Joined
·
1,518 Posts
I don't think a wash would make a diff. It's oils and other volatiles that are in all the parts. (like sealants, gaskets, and heat shields)
 

·
Registered
Joined
·
360 Posts
I had a burnt smell for about the first 500 miles then it went away. No problems since - even after an oil change.
 

·
Registered
Joined
·
1,845 Posts
When I order mine, I will ask dealer to wash the engine at delivery.
The dealer will likely do this anyway, or decline. In either case, it won't make a difference, and ...

...are you really interested in trusting a person being paid minimum wage, and who has a pressure washer, to soak down your brand new engine and electrics under the hood? Fully realizing you did not ask for my advice, I'm going to leave it here regardless - don't ask them to wash it.

Seriously - the "burning" isn't like a 4 alarm conflagration slewing smoke and fumes. Its more like a dog farting. You smell something, its kind of "off". It occurs to you to look for the issue, then you get distracted by a TV add, the smell goes away and you're back to happy...except it'll be one of the geegaws in the truck distracting you, and while the dog might fart again...and again...the truck won't. ;)
 

·
Registered
Joined
·
34 Posts
I picked my truck up on July 3 and noticed the next week on my way home from work that I had a burnt smell coming in the truck. I did not smell it before even though I drove the truck over 1 hour home from the dealer. Since that time I still smell the burnt smell but not all the time only sometimes. Last weekend I smelled it after I was driving 10 miles on a hilly curvy country road and when I stopped it had a strong burnt smell coming out from under the hood. I checked but could not see anything wrong and smelling under the hood really did not work to pin point the source. I plan on towing my toy hauler camper with a Harley to Tennessee next week from MD. From what I've read here the smell may be normal but it still seems strange to still have the burnt smell after 900 miles. Any thoughts?
 

·
Banned
Joined
·
627 Posts
Tial_heatshield500x375.jpg It will go away at 8k miles. Its the fiberglass heat shield covering the turbo, and the fiberglass heatshields on the firewall and rear of the motor. It freaked me out real bad at first till I saw what it was. Its normal, I pressure washed the engine really good in the back twice. It helped a little.
 

·
Registered
Joined
·
4 Posts
I have 6,000 miles on mine and have been seeing lots of the white smoke when I stop.. Also smelling lots of fumes in the cab . Anybody have any up dates on this problem or solutions.
 

·
Registered
Joined
·
609 Posts
1 - 20 of 36 Posts
Top