RAM 1500 Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter #1
Today, my '14 ED with 85,000 miles threw the P203e "reductant level sensor circuit intermittent/erratic" code. I've done some reading and understand it's most likely related to a sensor in the DEF tank. I have an extended warranty, so I'm wondering if this is something I should look into having fixed. I also have had a GDE tune for over a year now, and I'm thinking about a full delete when the truck is out of warranty. Would that resolve issues with the DEF system? Just looking for some advice. Thanks in advance.
 

·
Registered
Joined
·
12,664 Posts
First I would call GDE and explain what happened. They are great at discussing and helping their customers. With GDE turning off the DEF sensors there must be some issue with the actual pump or tank.

Usually don't have this kind of issue with GDE. Contact them and report back.
 

·
Registered
Joined
·
3,854 Posts
I don't think GDE turns off any DEF sensors. I think they're less likely to cause an error code, making them less finicky, but I don't know about turning them off all-together.

Yes, a delete tune would remedy any DEF related sensor issues.
 

·
Registered
Joined
·
1,701 Posts
Today, my '14 ED with 85,000 miles threw the P203e "reductant level sensor circuit intermittent/erratic" code. I've done some reading and understand it's most likely related to a sensor in the DEF tank. I have an extended warranty, so I'm wondering if this is something I should look into having fixed. I also have had a GDE tune for over a year now, and I'm thinking about a full delete when the truck is out of warranty. Would that resolve issues with the DEF system? Just looking for some advice. Thanks in advance.
Just call GDE and they can turn off your DEF for $50 and they upgrade you
It’s kind of nice when your def sits at 1/2 all the time and never moves LOL
 
1 - 4 of 4 Posts
Top