RAM 1500 Diesel Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
2 Posts
P24AE Code

Darn light, I am beginning to think it is something other than the sensor causing the problem. I can run for a week without it coming on. Then idle at the boat ramp while launching & loading and as I drive off BAM it's on. Still gona wait on the reprogram and money but consider doing the GDE tune after that.
Afternoon Kevin, I'm experiencing the same problem myself. I was wondering if you have tried this for the MAP Sensor/EGR Tube:

.

Read on another forum that is a common problem and likely the issue. Gave mine a clean today and going to see if it make any difference. My sensor was pretty blocked up. Just throwing another option out there. Here is the other forum I was monitoring: https://www.ecodieselram.com/forum/threads/p24ae.2042/#post-19730
Here is some pics of mine today when I pulled it apart.

Auto part
Tire Shoe Auto part Synthetic rubber
 

· Registered
Joined
·
2 Posts
Well took mine in for the FCA Recall (Class Action) and 10 miles before the dealership I got CEL. Told dealership it came on right before pulling in and they said they would look into it, but most likely it was nothing (LOL). Well, they gave it back to me 4 hours later and said the code was old so they cleared it and to come back if it was an issue again. I live 2 hours from the dealer, don't think I'm just coming back if there is an issue. Well to my luck, I made it 5 miles before CEL came back on for same code P24AE. They ended up replacing the diesel particulate sensor after that. I would love to tell you that this fixed the problem, but I decided to get rid of this piece of shit. Oil cooler failure at 12K miles and then random P24AE issues, emissions issues; I'm just over this engine. I traded it in and upgraded.

I hope you all have better luck and continue to fight the good fight fixing these issues! Off to the 2500 forums to deal with new issues lol.
 
1 - 2 of 2 Posts
Top