RAM 1500 Diesel Forum banner
201 - 211 of 211 Posts

·
Registered
Joined
·
223 Posts
Discussion Starter · #201 ·
Great idea on improving the location of the bedplate!

As far as the bearings, all of mine looked the same and came in King packaging (I purchased 2 sets from Summit and 2 from Ebay).

I found that mine measured between 0.0015"- 0.002" for the mains (with no RTV) using plastigage. I'm guessing that with RTV, they are probably around 0.002"- 0.0025". Did you check the clearances on yours?
 

·
Registered
Joined
·
223 Posts
Discussion Starter · #203 ·
Yes very much the same but the seized journal was .0010'' had to be resized.
Funny enough, I talked to 3 different machine shops that said they could not resize/line hone one of these blocks with a spun main. I'm beginning to think they were just lazy or did not want to mess with it...
 

·
Registered
Joined
·
7 Posts
Mine was not really damaged because I got it early. When I did the messuring without the bearings the single seized journal was slightly smaller,hopefully it was the reason for the failure , I honed it and after fitting with plasigauge it was good. I saw the stamped logo from one of your pics and I am nou confident that I installed king brand bearings. To do a compleet linebore the bed needs to be machined like a head machining. Oilpump gear mesh might need to be ajusted aswell. Have you fitted oil pressure gauges and what pressure do you have at hot idle?
 

·
Registered
Joined
·
223 Posts
Discussion Starter · #205 ·
I haven't added an oil pressure guage, but indicated at hot idle is 17-19 PSI, and that hasn't really changed in 11k miles. I think the King bearings are pretty good quality overall.

The shop that did the work on my experimental engine with the Benz pistons said they thought they could do the line bore, and if I have a block they will try it out.
 

·
Registered
Joined
·
223 Posts
Discussion Starter · #206 ·
Finally got into the engine this weekend. No damage to the bottom end or the small end of the rods, so looks like I was able to shut it down quickly enough. I'm going to take my time putting it back together since I don't really have anything to put it in, but this time I might skip the latex gloves :D
 

·
Registered
Joined
·
1,721 Posts
Great update as usual @67_Valiant . Interested with the feedback on the modifications you put in the motor on how does it sounds and feels as well as comparative performance this has been a great read. Thanks!
 

·
Registered
Joined
·
223 Posts
Discussion Starter · #208 ·
Great update as usual @67_Valiant . Interested with the feedback on the modifications you put in the motor on how does it sounds, and feels as well as comparative performance this has been a great read. Thanks!
Thanks! I did post a video of the engine running before I had the knocking problem here:

 

·
Registered
Joined
·
1,721 Posts
Definitely a different sounding EcoDiesel almost has an industrial tone which is cool very interesting and yet its very smooth. Is it me or was there a leaking air line there is a strong sound of air escaping somewhere. Nice build
 

·
Registered
Joined
·
223 Posts
Discussion Starter · #210 ·
Definitely a different sounding EcoDiesel almost has an industrial tone which is cool very interesting and yet its very smooth. Is it me or was there a leaking air line there is a strong sound of air escaping somewhere. Nice build
Yeah- the grommet on the brake booster failed, so it was sucking air pretty bad. I should do another video once it's running again without the hissing LOL
 

·
Registered
Joined
·
1,721 Posts
Yeah- the grommet on the brake booster failed, so it was sucking air pretty bad. I should do another video once it's running again without the hissing LOL
Glad its just a grommet, I did try to repost your video so it could be embedded directly but I guess the youtube 'tik tok' style shorts isn't compatible with this site @admin
 
  • Like
Reactions: 67_Valiant
201 - 211 of 211 Posts
Top