RAM 1500 Diesel Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
Ok so here is my deal. 2015 Laramie Limited ED. I always run my lights in the "Auto Mode" as i have DRL's. So i hook up my trailer to the truck and all was good and about a mile down the road POOF, no triler lights or DRL's. So then i turned the dial to lights "ON" and all the lights work on the truck and trailer. I checked all my fuses under the hood because i couldn't find a specific one for DRL lights and they are all good. I have the Alpha software and the MX+ connector and there are no fault codes either. Any advice would be great.
 

·
Super Moderator
Joined
·
4,326 Posts
So it's just when your in the Auto mode the lights don't work? The light sensor is on the center dash speaker grill. There is two versions, one for truck with dual climate control, the other for the ones without. If the lights work in the On position but not Auto, I'm guessing it has something to due with the sensor or the headlight selector switch
The actual trailer lights won't effect the truck lights as they each have a separate fuse and relay for each pin. The relays are internal to the Power Distribution Module (fuse box), you actually check for power at the fuses with the lights On.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #3
Ok, i went out and put the dial on "Auto" and threw a rag over the sensor on the dash and all the lights came on for the truck and trailer like they should, take the rag off and the lights go off, so that part is working. Does this sensor also control the DRL lights ?? I also found a "Fault" P1009 this time for a "Humidity Sensor Module" must have missed it last time ???
 

·
Super Moderator
Joined
·
4,326 Posts
Does this sensor also control the DRL lights ?? I also found a "Fault" P1009 this time for a "Humidity Sensor Module" must have missed it last time ???
The DRLs are activated if the truck is in gear and the parking brake is not set. The DRLs will also activate when you remote start the vehicle. As far as I know the sensor on the dash is just for telling the vehicle when to "Auto" turn the headlights on and a solar sensor for the HVAC system.
The humidity sensor is on the windshield just to the right of the rearview mirror under a black snap on cover for truck with Dual Zone Auto Climate control(single zone ATC if the conversion was done). The humidity sensor communicates with the HVAC module which is under the dash, right side of the passenger area.
The humidity sensor is about $50, the sun sensor is about $30

68230114AB Sun Sensor
55111389AF Humidity Sensor
 

·
Registered
Joined
·
43 Posts
Discussion Starter #6 (Edited)
Yep, i just tried the remote start and the DRL's came on but soon as i get in, press the break, hit the start button and put it in drive and the DRL lights went out again. ?? Do you think i should swap out the dash sensor ??
 

·
Registered
Joined
·
4,396 Posts
Use AlfaOBD to confirm the drl setting. You can also use the app to test all the light circuits individually.

I believe remote start activates the parking lights, not the drl's.
 

·
Super Moderator
Joined
·
4,326 Posts
Yep, i just tried the remote start and the DRL's came on but soon as i get in, press the break, hit the start button and put it in drive and the DRL lights went out again. ?? Do you think i should swap out the dash sensor ??
Check for a setting for the DRLs in the radio. You may have the selection to turn them On/Off. It's normal for the DRLs to go off after you remote start and then turning the ignition on. You don't have the parking brake set? (the DRLs turn off).
I doubt it's the sensor as that for the headlights and running lights too.
 

·
Super Moderator
Joined
·
4,326 Posts
I couldn't find the DRL settings in Alpha. Is it under "Body Control"
This is what I enabled to get the DRLs enabled on my truck under Body Computer:
CBC Features: DRL Configuration
Select “Optional DRL”

CBC Features: DRL Lamp location (several to choose from, high beam, low beam, fog lamp, dedicated and SRT Light Bar) Known working high beam, low beam, turn signal and fog lamp.

CBC Features: DRL Dropout Enabled
Select “yes”

ECU 3: DRL Customer Setting Enable/Disable
Select “yes”

Customer Service Menus: Daytime Running Lights CSM
Select “yes”
Don't enable the DRL drop out if your using the High or Low beams for the DRLs
If your truck DRL configuration is set as Canadian, the DRL in the radio menu probably won't work.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #12
I went into the Active Diagnostics in Alpha and it tells me the Daytime lights are not active. So i go in to turn them on and when i click on "Left Daylight Lamp" for example to test it, it tells me FAILED, Conditions are not correct or Request sequence error. ??
 

·
Registered
Joined
·
43 Posts
Discussion Starter #13
Here are a couple screenshots of what it tells me. The one tells me the test for the "left Day Light Lamp" failed. the other is a screenshot of my system status where it tells me my "daylight Lamps are Off" ??
 

Attachments

·
Registered
Joined
·
43 Posts
Discussion Starter #14
Ok, just figured out i need to go to "Car Configuration Change" after i go to "Body Control". Going to give this a shot in the morning. Looks pretty straight forward from there
 

·
Super Moderator
Joined
·
4,326 Posts
Be sure to upload and save a copy of the BCM configuration before making changes with AlfaOBD. Just in case something goes wrong you can refer back to the original configuration
 

·
Registered
Joined
·
4,396 Posts
Ok, just figured out i need to go to "Car Configuration Change" after i go to "Body Control". Going to give this a shot in the morning. Looks pretty straight forward from there
This is the correct location for it. Let us know what you find.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #17
Ok, so here is what i have.

CustSetMenu 1 - Daytime running Lights - ON
ECUConfig 3 - DRL customer setting - Enabled
CBC I/O - Right Dedicated DRL Lamp Output - YES
CBC I/O - Left Dedicated DRL Lamp Output - YES
CBC Features DRL Configuration - Optional DRL
CBC Features - DRL Dropout Enabled - YES
CBC Features DRL Lamp Location - Tried Low Beams first then switched to Turn Signal

Everything works like it should on the truck with the changes but still no running light s on the trailer when in dial is in auto and truck is in Drive. This is just odd because like i said in the beginning, my trailer running lights worked when the truck was in "Auto" for a couple miles. Now i have to have the dial in "ON" position to get trailer lights.
 

·
Super Moderator
Joined
·
4,326 Posts
If your trailer running lights work with the headlight switch in the On position but not when in Auto, the problem most likely in the BCM, I doubt it's the switch.. You said the Auto feature works so that rules out the sensor.
Have you tried pulling the battery cable for a few?
 
1 - 20 of 24 Posts
Top