RAM 1500 Diesel Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1 (Edited)
Electronic Throttle Control (ETC) problem - UPDATE

10/07/14 Had my eco-diesel for less than 1,000 miles. Today taking off ramp from highway, my ETC warning light came on and the engine did not respond to the accelerator at all. It went into a fast idle and stayed there. Pulled over and shut the truck off and restarted thinking it would reset, did not. I was close to home, so I kept going. Truck would not shift out of 1st gear. Called dealer and he recommended that I not drive the truck and have it towed to the dealership. As of 5:00 pm, they still had no resolution to the problem.

I searched the web and this seems to be a recurrent problem for quite some time, starting around 2004. In some cases, the truck will accelerate with the driver having no control. Sounds like the Toyota issue a few years back.......

not happy

10/09/14 UPDATE:
Took service department 1 1/2 days to come up with a diagnosis, some sensor in the exhaust system. Naturally, they did not have the part in stock and had to order over night delivery. Today (Friday) they called and that part did not solve the problem and they have to order another part (again not in stock) and over night delivery, but since it is Friday, the part will be delivered on Monday. This does not bode well for repairs on the Eco diesel.

Icing on the cake: When asked why the diagnosis was incorrect, I was told that the problem could be caused by a couple of different defective parts. I then asked why they didn't order both parts and replace the defective one. I was told that Chrysler would only allow them to order one part at a time for a warranty claim.......... Sure hope this next part takes care of it

Good Luck on warranty work!

UPDATE 10/12/14
Part did not arrive, it is now back ordered and earliest delivery is now 10/16 (Friday)
 

·
Registered
Joined
·
1,518 Posts
This is the first time I've heard of an ED having a throttle issue.

Please keep us updated as the dealer figures it out.
 

·
Registered
Joined
·
13,685 Posts
Oh my. It would be a real bummer is the transmission would not shift out of gear.

This electronic stuff is unsettling. Glad you were not wrecked and/or injured.
 

·
Registered
Joined
·
13,685 Posts
Thanks for the update. Hope they get it right Monday.

Fellow at the dealership told me I will have trouble cutting into the fuel filler hose to make a feed for my extra fuel tank. He said some sensor would detect a pressure change, throw out a code and turn some light on. He said there would be no way to turn that light off.

I told him I have a roll of black tape.
 

·
Registered
Joined
·
369 Posts
Thanks for the update. Hope they get it right Monday.

Fellow at the dealership told me I will have trouble cutting into the fuel filler hose to make a feed for my extra fuel tank. He said some sensor would detect a pressure change, throw out a code and turn some light on. He said there would be no way to turn that light off.

I told him I have a roll of black tape.
I'm a doctor...I usually use a band aide!!!!
 

·
Registered
Joined
·
2,332 Posts
:mad:Picked up Outdoorsman today at Dave Smiths motors in Kellogg ID Headed back to Elk Wa, 90 some miles. It has 113 miles on it now setting in the garage.Four times I had this problem the with the ELECTRONIC THROTTLE CONTROL (ETC) . Luckily Each time i was able to get off the road. Put truck in park, shut it down, turned it back on and started right up. I was off the Interstate so the traffic was not fast and furious, so I drove very slowly the rest of the way home. It did it the 4th time as I turned into my drive way off the gravel road.

Was this resolved for you< rscovell > if so please let me know what they said caused it. I will be calling a local dealer service department in the AM plus calling the service manager at Dave Smith Motors. Other than that BS happing It was a great ride did great coming through the mountains. :(
 

·
Registered
Joined
·
610 Posts
New PCM with reflash dated 10/10/2014.

Get them to check the wire harness under the driver seat (outside), and under the air-filter.



Sent from my iPhone 5S using Tapatalk
 

·
Registered
Joined
·
2,332 Posts
New PCM with reflash dated 10/10/2014.

Get them to check the wire harness under the driver seat (outside), and under the air-filter.



Nemesis, Thanks, printed your reply out , sure hope this can be resolved fast and easy. RB33
 

·
Registered
Joined
·
2,332 Posts
Took the truck back to the dealer today and they worked it right in. All test were clear or the readings were right where they are supposed to be. The computer said it was more than likely caused by the driver touching the accelerator & break at the same time well coming to a stop.
<I PLEAD GUILTY TO THIS. > AS IT IS BAD HABIT I HAVE DEVELOPED. So I drove the 90 miles home and was very careful to keep my left foot off to the side away from the pedals. ;) 3677.jpg
 

·
Registered
Joined
·
592 Posts
Hmmm, so no brake burnouts. Rats!

:(
 

·
Premium Member
Joined
·
1,086 Posts
To the OP, did they resolve your issue yet? I'm having the exact same issue you described with the fast idle, and the truck refusing to go beyond first gear. Only 2300 kms on the clock.
Thanks.
 

·
Registered
Joined
·
1 Posts
My ED has 93k miles on it. The last 2 months the error message has came on 4 times. I've been removing it by clearing the computer at an auto parts store. Seems to last a few weeks before I happens again. The last time it happened I took it to the dodge dealer and they didn't really have a solution. They replaced the file filter and air filter and said hopefully that fixes it. The next day it happened again. I cleared it at the auto parts store and it happened again that same day. After reading all the post on forums about this issue I have no confidence in taking it to dodge to get it looked at. Has anyone ever came up with a confirmed lasting fix for this issue? Thanks!
 

·
Registered
Joined
·
1 Posts
I’m having the same issue with mine today. Etc code and lost all power. This is the second time it’s happened. Is there a recall on this?
I have a 2015 ecodiesel that just gave me an ETC code really need to know whats going on I am afraid to drive it like this anf not sure I can afford the $4000 fix everyone is getting.
 

·
Registered
Joined
·
62 Posts
ok, was in one of the fb threads and a fella or two mentioned the MAP sensor....the on the intake manifold plenum.. gets cruded up and wont read properly and cause the issue, a torx #40 bit and taking the sensor out and cleaning it resolved the issue, then used a code reader to clear the code... Hope it helps.
Just went back and stole the pic from the post... Big thanks to Jerry for posting it.
87643
 

·
Registered
Joined
·
62 Posts
stole more instruction from him.. wonder if he is on here....

Clean this sensor
Map sensor, gets carbon built up, doesn’t let enough air in for reading turbo correctly, and throws that , and loose power, clear code with machine.

they said to use brake cleaner,i'd use mass air flow sensor cleaner just so it does not damage anything.

Hope this helps.
 
1 - 19 of 19 Posts
Top