RAM 1500 Diesel Forum banner

Exhaust filter message after delete

3707 Views 8 Replies 7 Participants Last post by  Critter
I just purchased a 2016 ecodiesel ram 1500.
Previous owner did the def delete. Now i hace a message that wont go away about exhaust filter being at 0%. what needs to be done to get this message removed? thanks
89838
See less See more
1 - 9 of 9 Posts
Needs a tune.
Welcome to the forum....
I'm not very well versed in this, but yes, if the previous owner just did the delete without a tune to compensate for the lost sensors you will get some codes.
If able you should contact the P/O and ask him what he did. If he did tune it I'd call them and ask what to do.
Some tuners dont know how to properly reset that message and just recommend not tuning a truck if it has messages like that. Yours was probably done by one of those tuners. There is some resets that can be done with alpha obd that sometimes work but your better off finding a different tuner.
  • Like
Reactions: 1
Did you ever get it to clear? I just tuned and deleted my 2016. I am getting the same message just 100% full
Ok so just for anyone else having this issue you can get it to clear. You will need to download Alfa OBD and have a Bluetooth OBD plug once you connect to your truck or EcoDiesel clear the exhaust particulate filter regeneration once it reads 0% flash back to stock tune and run for 20 sec, then flash back to your stage 2 tune the message should be gone hope this helps.
  • Like
Reactions: 1
Ok so just for anyone else having this issue you can get it to clear. You will need to download Alfa OBD and have a Bluetooth OBD plug once you connect to your truck or EcoDiesel clear the exhaust particulate filter regeneration once it reads 0% flash back to stock tune and run for 20 sec, then flash back to your stage 2 tune the message should be gone hope this helps.
Do you have to have the Alfa OBD and OBD Plug or can I use the HP Tuner plug and software?
Ok so just for anyone else having this issue you can get it to clear. You will need to download Alfa OBD and have a Bluetooth OBD plug once you connect to your truck or EcoDiesel clear the exhaust particulate filter regeneration once it reads 0% flash back to stock tune and run for 20 sec, then flash back to your stage 2 tune the message should be gone hope this helps.
Can I get any specific info on how to get 0% off the display screen after the tune has been installed in the truck when I can’t set back to stock without losing tune?
1 - 9 of 9 Posts
Top