RAM 1500 Diesel Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Never tried it during the test drive, although I tried everything else on the truck. Found out my horn doesn't work, called the dealer and have an appointment on Wednesday. Hopefully is just a loose wire or connection. This has been the only issue with the truck. Sure could have used the horn several times the way some of these yahoos drive around here in SE Michigan.
 

·
Registered
Joined
·
13,970 Posts
Bummer.

Good reminder. Like my broken windshield washer, didn't find out till I tried it. Don't think I ever tried my horn. Hope to remember to try the horn.

Been waiting now into the third week for a washer bottle/pump. Hope your horn is fixed quite a bit faster.
 

·
Registered
Joined
·
42 Posts
That sucks that your horn doesn't work at all, would figure they would check that before shipping it out. I have noticed that my horn has a delay from when I push the horn to when it sounds. Has anyone else noticed that? Never experienced this on any other car or truck. Hope they figure out what is wrong, keep us posted.
 

·
Registered
Joined
·
13,970 Posts
Was told you can't do a quick beep beep beep or something like that. It just does not work because of some kind of delay. Did not know it had one at the start.
 

·
Registered
Joined
·
1,845 Posts
That sucks that your horn doesn't work at all, would figure they would check that before shipping it out. I have noticed that my horn has a delay from when I push the horn to when it sounds. Has anyone else noticed that? Never experienced this on any other car or truck. Hope they figure out what is wrong, keep us posted.
Lovely - beep by wire... :(
 

·
Registered
Joined
·
107 Posts
got up this morning and opened the fuse panel, found a fuse in there loose in a spare spot. stuck it in slot F42 and horn works. they must remove it during inspection to keep it from going off during checks.
 
1 - 8 of 8 Posts
Top