RAM 1500 Diesel Forum banner
1 - 20 of 26 Posts

Registered
2016 Laramie Limited Crew Cab 4x4 with Air Suspension and GDE Hot Tune. 253,000 KM.
Joined
1,864 Posts
Discussion Starter · #1 ·
2016 with 255,000kms.
Drove to work this morning without issue. Came out to head home and got warning on instrument cluster as soon as I drove away.. "Immediate Air Suspension Service/ Repair required"
I went from the best riding truck to the worst while it sat in the parking lot. I'm not on the bump stops but its got to be close. The truck seems to be level on all four corners but does look an inch or two lower than normal. The ride is very bouncy and then hitting the bump stops on large bumps.
Where should I start?
I do have AlfaOBD. Any help would be appreciated.
Font Gauge Speedometer Vehicle Auto part
Font Gauge Speedometer Vehicle Auto part
 

Registered
2016 Laramie Limited Crew Cab 4x4 with Air Suspension and GDE Hot Tune. 253,000 KM.
Joined
1,864 Posts
Discussion Starter · #3 ·
Yes. It was -7C here this morning. No doubt part of the issue.
 

Registered
Joined
1,663 Posts
Hi: Ecosparky... Well wouldn't that just let the wind out of your sails!!!
Dieseldragon North shore of Lake Erie.
 

Registered
2016 Laramie Limited Crew Cab 4x4 with Air Suspension and GDE Hot Tune. 253,000 KM.
Joined
1,864 Posts
Discussion Starter · #7 ·
Check the fuse for the compressor
Yes. I'm going to sneak the truck into the heated U/G parking lot at the condo near work and let it thaw out today then start troubleshooting.
 

Registered
Joined
387 Posts
Dang. I thought it was cold this morning at 65.


Sent from my iPhone using Tapatalk Pro
 

Registered
Joined
1,465 Posts
Yes. I'm going to sneak the truck into the heated U/G parking lot at the condo near work and let it thaw out today then start troubleshooting.
Hey buddy didn't realize you are that close to the Arctic Circle.....geez. Have a big ol' steaming pot of coffee on standby, no doubt this is weather related hope it's just an uncooperative fuse.
 
  • Like
Reactions: Ecosparky

Registered
2016 Ram 1500 Ecodiesel 4x4 CC Laramie
Joined
843 Posts
I remember your post few months ago when it acted up the first time. I would check for leaks first and have alfa obd on hand to aid.
 

Registered
2016 Laramie Limited Crew Cab 4x4 with Air Suspension and GDE Hot Tune. 253,000 KM.
Joined
1,864 Posts
Discussion Starter · #12 ·
what... working on a truck in freezing temps doesn't entice you? come on, where is your sense of adventure.
Been there many times......but I try to avoid it if possible. My old mans body is starting to reject that kind of work. It lets me know every time.
 

Registered
2016 Laramie Limited Crew Cab 4x4 with Air Suspension and GDE Hot Tune. 253,000 KM.
Joined
1,864 Posts
Discussion Starter · #13 ·
I remember your post few months ago when it acted up the first time. I would check for leaks first and have alfa obd on hand to aid.
So I thawed the truck in the U/G. Pulled the F5 40amp fuse and tested it. At least fuses are getting blown around here.
I think I dodged a bullet. System is working normal........for now.
We should all carry a couple spare 40A fuse (if you have Air Suspension).
 

Registered
2016 Laramie Limited Crew Cab 4x4 with Air Suspension and GDE Hot Tune. 253,000 KM.
Joined
1,864 Posts
Discussion Starter · #14 ·
Hey buddy didn't realize you are that close to the Arctic Circle.....geez. Have a big ol' steaming pot of coffee on standby, no doubt this is weather related hope it's just an uncooperative fuse.
This isn't that cold yet. Just want to go to bed tonight and wake up on May 1st.
 

Registered
Joined
5 Posts
I had that same message appear on my old 2016 Rebel. Believe it or not It was the battery causing it. I replaced the battery and voila the message went away and never came back.
 

Registered
2016 Ram 1500 Ecodiesel 4x4 CC Laramie
Joined
843 Posts
Are you willing to swap weather with Vancouver for this winter?
 

Registered
2016 Laramie Limited Crew Cab 4x4 with Air Suspension and GDE Hot Tune. 253,000 KM.
Joined
1,864 Posts
Discussion Starter · #17 ·
Are you willing to swap weather with Vancouver for this winter?
Too much rain in Vancouver recently but the temps are better than here. I'd swap.
 

Registered
2016 Laramie Limited Crew Cab 4x4 with Air Suspension and GDE Hot Tune. 253,000 KM.
Joined
1,864 Posts
Discussion Starter · #18 ·
Now that the Air suspension is somewhat sorted out, the evic reads Service Front Park Assist System.....WTF
Looks like I'll have to replace the sensors for the knock off Amazon set I have on the shelf.
 

Registered
Joined
1,465 Posts
Now that the Air suspension is somewhat sorted out, the evic reads Service Front Park Assist System.....WTF
Looks like I'll have to replace the sensors for the knock off Amazon set I have on the shelf.
Glad you got resolution on the Air suspension. One thought does come to mind because these trucks are so electrically power dependent is that some of the electronics can be erratic when there is a slight drop in voltage, I know personally I tried to push battery replacement a bit too long (6 years on oem battery) started getting random radio, throttle evic, park sensors. I replaced truck battery and voila everything back to normal, it's just the nature of these power dependent systems.
 
  • Like
Reactions: Ecosparky

Registered
Joined
84 Posts
So I thawed the truck in the U/G. Pulled the F5 40amp fuse and tested it. At least fuses are getting blown around here.
I think I dodged a bullet. System is working normal........for now.
We should all carry a couple spare 40A fuse (if you have Air Suspension).
If it's like any compressor pump that's driven electrically then cold weather will cause a larger current draw that will pop a fuse or trip a breaker. My compressor in the garage will pop the overload breaker on the side of the pump when the garage gets cold in the winter. If breaker or fuse pops in warm weather then the pump is going out!! Keep your fuses handy!!
 
1 - 20 of 26 Posts
Top