RAM 1500 Diesel Forum banner

121 - 129 of 129 Posts

·
Registered
Joined
·
309 Posts
I dropped my 2015 off this morning to get the AEM done and all its recalls since ive never had it back in since new. I was surprised at how well the young service girl was informed about the AEM and EGR cooler. They gave me a loaner to use without me even asking for one. I explained about the white smoke issue I had a few months ago but never has duplicated again. They will also check the intake for any melting without any codes. So far I couldn't ask for a better experience, I will follow up when I get it back.
 

·
Registered
Joined
·
309 Posts
I picked up the truck today and all recalls were completed and they even washed it for me. I checked the new egr cooler to make sure it was done. When I asked about the intake they said it didn't show signs of melting and should be good.
The Tech said that was the cleanest intake he has seen and wondered if I had work done to it after the smoking issue. I said no work done but I try to keep it all clean so it doesn't catch on fire. I headed home and have to say the new tune is way better than the stock original tune and wasn't half bad to drive. I hear there are better tunes though. I hope I am golden now.
 

·
Registered
Joined
·
864 Posts
So I just took my first towing trip with the new EGR and VA7. First thing I got nervouse when I smelled coolant about 3 minutes into the trip but it was short lived, must have been somewhere the AC could suck it in with the air.

As for VA7, the trip was a short 42 miles but the mpg was back to pre AEM with me getting 14.3mpg

Lag was not noticable and power seemed like before.

Oil temp was 222 at 83° ambient, honestly don't remember what it was before.

All in all I was happy with the performance.

Sent from my moto z3 using Tapatalk
 

·
Registered
Joined
·
791 Posts
So I just took my first towing trip with the new EGR and VA7. First thing I got nervouse when I smelled coolant about 3 minutes into the trip but it was short lived, must have been somewhere the AC could suck it in with the air.

As for VA7, the trip was a short 42 miles but the mpg was back to pre AEM with me getting 14.3mpg

Lag was not noticable and power seemed like before.

Oil temp was 222 at 83° ambient, honestly don't remember what it was before.

All in all I was happy with the performance.

Sent from my moto z3 using Tapatalk
I had a similar experience with coolant and when I got home checked under the truck and in the engine compartment... they filled the reservoir to capacity and I suspect it overflowed.
 

·
Registered
Joined
·
4,473 Posts
if it keeps oveflowing , the reservoir cap may have gone bad ,
my cap went bad and the truck turned into a Coolant factory , no matter how much I lowered / drained the degas
bottle , it kept going up . the new cap fixed it .
 

·
Registered
Joined
·
864 Posts
Yez, it was filled higher than normal, I'll keep an eye on it. I am literally a happy camper though ;)
 

·
Registered
Joined
·
791 Posts
if it keeps oveflowing , the reservoir cap may have gone bad ,
my cap went bad and the truck turned into a Coolant factory , no matter how much I lowered / drained the degas
bottle , it kept going up . the nehttps://www.johnfliesflyfactoryltd.com/w cap fixed it .
I'll keep an eye on it but I think they just filled it up a bit much. Looks good now. Taking a trip today.
 
121 - 129 of 129 Posts
Top