RAM 1500 Diesel Forum banner

1 - 10 of 10 Posts

·
Registered
2019 Ram 1500 3.0
Joined
·
5 Posts
Discussion Starter #1
Hello All, newbie to forum. I purchased my first diesel ever and chose the 3.0. Bought it new 2019. It currently has just under 2k miles. Just wondering if it's normal for 'low oil pressure' warning to come on at start up? Has anyone had this issue? When running warning goes out and doesn't come back. It happens at almost every start up.
 

·
Super Moderator
2015 Outdoorsman EcoD CC w/6.4' 4X4
Joined
·
4,418 Posts
Are you talking the red low oil indicator light? Yes that's normal, the oil pressure will be red on the 7" EVIC also.
Or are you saying it happens whileyou start the vehicle? Are you tip starting the truck? How to tip start just turn the key all the way to start and let go. (This is perfectly fine as it automatically waits for the glow plugs).
 

·
Registered
2019 Ram 1500 3.0
Joined
·
5 Posts
Discussion Starter #3
Thanks for quick response Crash. The warning comes out on the gauge cluster evic display when I turn the key to the on position without starting. Then when I start truck it goes away and will not display while driving.
 

·
Registered
Joined
·
4,434 Posts
to show you the light is not burnt ,
then it can come on if the problem ever happens for real ,
like a bunch of other lights in the dash .
 

·
Registered
2019 Ram 1500 3.0
Joined
·
5 Posts
Discussion Starter #7
Thanks guys appreciate your help. But why only comes on sometimes, not all the time.
 

·
Super Moderator
2015 Outdoorsman EcoD CC w/6.4' 4X4
Joined
·
4,418 Posts
I wouldn't worry about the low oil light unless is comes on after the engine is running or doesn't go out when you start the engine.
On my 7" EVIC, I usually remote start the truck as I'm walking to the truck. When I turn the key on the EVIC goes through a start up routine and the oil pressure goes red, done that since day 1.
 
1 - 10 of 10 Posts
Top