RAM 1500 Diesel Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
I have a 2016 Laramie longhorn with 72,000 miles, stage 1 SFT tune. While I am driving(usually about 15 minutes into my drive) I have a low voltage pop up on dash while driving, battery voltage is at 14, and drops down to 12 when it happens. I believe it makes the power steering shut off, screen shut off, and probably another thing or two. When it happens it definitely lasts less then a second, I have not noticed any major issues, but I don’t know what could be making this happen? Any help is appreciated!!
 

·
Premium Member
Joined
·
5,642 Posts
How many miles running that tune?
 

·
Registered
Joined
·
225 Posts
I plan on taking it into the dealership tomorrow to get them to reset it. I’ll keep you updated. Thanks!
If you take it to the dealership and they reset it, unless you've flashed it back to stock yourself, you'll lose your tune and have to pay for a new one or at least to get it restored.
 

·
Registered
Joined
·
906 Posts
Doubt it has anything to do with your ECU tune. More than likely the battery, alternator, or battery cable. You can have those items checked for free at Autozone.
 

·
Registered
Joined
·
1,663 Posts
I have a 2016 Laramie longhorn with 72,000 miles, stage 1 SFT tune. While I am driving(usually about 15 minutes into my drive) I have a low voltage pop up on dash while driving, battery voltage is at 14, and drops down to 12 when it happens. I believe it makes the power steering shut off, screen shut off, and probably another thing or two. When it happens it definitely lasts less then a second, I have not noticed any major issues, but I don’t know what could be making this happen? Any help is appreciated!!
Hi: Luke Scrimsher... I'd steer clear of the "Stealership" at all costs!!!
Dieseldragon North shore of Lake Erie.
 

·
Super Moderator
2016 SLT 4x4 Quadcab 3.53 with a cap
Joined
·
1,071 Posts
Take a hard look at the battery connections, main lug and a few others that have separate wires and fuses. Make sure they are really clean, put a battery charger on there for a few hours and see if it makes any difference. Can't hurt to try.
 

·
Registered
Joined
·
228 Posts
I've been running an SFT stage one going on 2 years with no complaints or problems, check the battery, alternator and connections, maybe the connector on the frame rail under the cab on the driver's side.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #13 ·
Well I took the truck into autozone, had them check the battery and alternator, both checked out and are working good. Took a obd2 reader to it because check engine light came on. Main code was p054f (idle control system- fuel quantity higher then expected) and a few secondary codes- u3017,p0420, p0128. Still not sure what I should do next.
 

·
Premium Member
Joined
·
3,102 Posts
Did the truck not come with a flash tool? It should have came with a flash tool that was used to tune it. You need to use that tool to load the stock file back in it. The charging system on these is controlled via the ecm and it has a special charging configuration to maximize fuel economy when full charging is not needed.
 

·
Registered
Joined
·
11 Posts
I have a 2016 Laramie longhorn with 72,000 miles, stage 1 SFT tune. While I am driving(usually about 15 minutes into my drive) I have a low voltage pop up on dash while driving, battery voltage is at 14, and drops down to 12 when it happens. I believe it makes the power steering shut off, screen shut off, and probably another thing or two. When it happens it definitely lasts less then a second, I have not noticed any major issues, but I don’t know what could be making this happen? Any help is appreciated!!
My 2016 did a similar thing, also have an old SFT stage 1 tune, I disconnected the battery and cleaned and retightened, noting a neg terminal was a bit loose and battery was good, had it checked, don't loose your tune, all good now, still running stock battery. Goodluck.
 

·
Registered
Joined
·
297 Posts
If you live in cold climate & don't plug it in... that's the problem. SFT has a known issue with cold starts & voltage drop, engine cuts out then restarts. I have same problem on my JGC that is stage 1 SFT. Some people say to contact them to get an "updated" tune. Well when I contacted them, they said I had the most recent tune. Told me it was my battery. Replaced battery & still happens. Well, wife can't remote start when temps are below 25F unless it's plugged in.

I wouldn't go to dealer... reach out to SFT & have them make it right.
 

·
Premium Member
Joined
·
5,642 Posts
I wouldn't go to dealer... reach out to SFT & have them make it right.
Good luck.

With tuning, I believe you really do get what you pay for.
 
1 - 17 of 17 Posts
Top