RAM 1500 Diesel Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I sure hope this is an ez fix...first time driving that needed heat on and no heat. Turned up to 80F and cold air blowing in. I bought my new ECD truck from a dealer in Ohio and was shipped to my house as you could not find them local to me.

Called my local dealer and my appt in a month away....are you kidding?
Any suggestions on how to troubleshoot? You can control this from the knobs and from the screen with the same cold result. Thankfully, the seat heaters work. In VT now and its 32F at night....heating season has started.

Love the new truck....amazing ride, 30mpg....what is not to like.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #5 ·
so convinced a local dealer (traveling in VT) and he looked at the truck. He had one 1500 that had a pinched line after the three way valve. That was not it. Said the troubleshooting is trial and error and replacing control parts. My local dealer will not have time until the end of OCT.
 

·
Registered
2016 Laramie Limited Crew Cab 4x4 with Deleted Air Suspension and GDE Hot Tune. 276,000 KM.
Joined
·
2,288 Posts
I sure hope the dealer checked the coolant levels. When I lost heat I found coolant was down in the tank and took two gallons to fill it. It was being ingested into the intake via a cracked egr cooler.
 

·
Super Moderator
2016 SLT 4x4 Quadcab 3.53 with a cap
Joined
·
1,301 Posts
Was just thinking the same thing....great suggestion.
Ah before you do that, realize those little defrosters you plug into the power port run about 10 amps and only put out about 110 watts, I had one and took it back. It would barely clear a small 6 inch diameter "hole" in the windshield at 30F and it ran for about 15 minutes.
 

·
Registered
Joined
·
6,366 Posts
This has happened to me once, I believe it was a stuck 3way valve, although it did not trigger a CEL.

I rear the fix online and it worked for me. I downshifted until RPM hit 3000 and I held it there for a minute or so. Valve unstuck itself and heat came right back. Hasn't happened since.
 

·
Registered
Joined
·
149 Posts
I had this issue a few years back and dealt with it for over a year. I found that starting and restarting the truck would sometimes fix it. Sometimes going full cold and back to full hot while turning on and off the air would fix it. Of course it would always work fine at the dealer. In the end my engine went out and the new long block solved my no heat issue. The dealer never could duplicate it.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #17 ·
so four days at the dealership and they can not figure it out. Mix damper is fine, control valve to heater is fine, return water flow is fine (not sure how they checked this). Outside air damper is fine....sending a ticket into headquarter on what to do next.
 

·
Premium Member
2016 Big Horn 4X4 Engine and Transmission tuned by no longer available (but truck runs good)
Joined
·
215 Posts
so four days at the dealership and they can not figure it out. Mix damper is fine, control valve to heater is fine, return water flow is fine (not sure how they checked this). Outside air damper is fine....sending a ticket into headquarter on what to do next.
several years ago, and for whatever reason wife's outside temp sensor (behind front bumper on explorer of all places) was faulty, and it was actually blowing in A/C air, our fall/winter is nothing like you're experiencing, but think running the A/C in 40-45 degree weather drove us batty, had to wear winter clothes in it till repaired and forget about defrosting

her explorer and Miata were our first vehicles with automatic climate control and both have exhibited peculiarities (older vehicles though 2013& 15)

hope you get it solved soon(y), too cool for that :oops:
 

·
Registered
2019 RAM 1500 Classic Tradesman 4X2 EcoDiesel
Joined
·
764 Posts
I sure hope this is an ez fix...first time driving that needed heat on and no heat. Turned up to 80F and cold air blowing in. .......................
Do you get the electric heating for the first 5 or 10 minutes? It works when heat dial is all the way up and fan is on. Perhaps the climate control system complicates that.
 
1 - 20 of 22 Posts
Top