RAM 1500 Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
Hey all,

Hit the remote start this morning and had a shut down 10 seconds later. Key start and noticed MIL on...crap.

Pulled a P203C code: Reductant Level Sensor Circuit Low. Cleared code, reappeared later this afternoon on the next start.

Anybody else come across this one?

skydog
 

·
Registered
Joined
·
42 Posts
Discussion Starter #2
Anybody at all?
Has me worried that the DEF tank may need to be replaced.
Is it true the level sensor is hard mounted in the tank and unservicable?

Anybody recommend a diagnostic approach? I couldn't seem to find any info on the forum.

Many thanks,
 

·
Registered
Joined
·
13,535 Posts
In the past the solution seems to be a delete program. You are right that the DEF tank level sensor is not something that is serviceable. Replacing the tank is an option for that code. A better option is removing the tank from the system.

Ask D&D Diesel, in Canada< what they might be able to do for you.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #4
Thanks Captainmal. Can't seem to find anything D&D Diesel in Canada.....

If the DEF tank is pulled/shut out, does that go by way of a full delete or partial? what else needs to be done keeping the surgery to a minimum. I'm sure a tune amendment is required and I hope I'm still safe with GDE given Canadian status.

Does anybody have a wiring schematic of this system? I would like to attempt some high level checks (connectors/fuses etc.) before I give in to a larger project or worse, a visit to the dealer.

Hoping to confirm through DMM testing that the sensor is pooched.

Any advice/output values etc. on this would be much appreciated.

Thanks folks,

sky
 
1 - 4 of 4 Posts
Top