RAM 1500 Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Hey all, I know there are several threads on resetting the oil life meter, but my problem seems to be slightly different.

A week or so ago, I installed a GDE tuned ECM (thing is magic by the way) on my 2016 ED, and followed their directions to reset the oil life meter. Ignition to 'RUN', gas pedal to the floor three times in the first 10 sec, ignition off. Turned the truck on, and the 'Change oil now' message is gone, and the meter shows 100% life and '0 miles since reset'.

However, in my next few hundred miles of driving, the oil life counter isn't decreasing at all. It still shows 100%, and '0 miles since reset'. I used the EVIC menus to reset the counter again, with no change to this behavior, and even did the ignition/pedal operation again. Oil life counter still stuck on 100%.

It's not really an issue because I change at even 10k intervals anyway, but does anyone know how to fix this annoyance?

Thanks!
 

·
Registered
Joined
·
744 Posts
Hey all, I know there are several threads on resetting the oil life meter, but my problem seems to be slightly different.

A week or so ago, I installed a GDE tuned ECM (thing is magic by the way) on my 2016 ED, and followed their directions to reset the oil life meter. Ignition to 'RUN', gas pedal to the floor three times in the first 10 sec, ignition off. Turned the truck on, and the 'Change oil now' message is gone, and the meter shows 100% life and '0 miles since reset'.

However, in my next few hundred miles of driving, the oil life counter isn't decreasing at all. It still shows 100%, and '0 miles since reset'. I used the EVIC menus to reset the counter again, with no change to this behavior, and even did the ignition/pedal operation again. Oil life counter still stuck on 100%.

It's not really an issue because I change at even 10k intervals anyway, but does anyone know how to fix this annoyance?

Thanks!
I would check with GDE first, go from there. FWIW, this is a new problem that I've heard of.
 

·
Registered
Joined
·
12,648 Posts
Think this is the second one like this. Seem to remember the other was after an AEM programming and then the replacement of the GDE.

Coincidence maybe. Ask GDE.
 

·
Registered
Joined
·
3,384 Posts
gotta be an error in the steps to reset , wouldn't be the first time ,
last time same situation was mentioned , the member ( howie12 )was not doing the right moves at the end of the prorcedure ,
..
couple exemple methods I copied before :
1-
"" by howie : Oil life is now reset. ,, I did not interpret the reset instructions correctly.
First you push and hold > to reset. Then the confirm screen comes up.
DO NOT GO DIRECT TO PUSH > TO CONFIRM> YOU MUST FIRST SCROLL THE SCREEN
UP OR DOWN TO GET THE OK IN THE CENTER WINDOW THEN PUSH > TO CONFIRM
..
2- Other oil life reset method :
for Laramie Ecodiesel push button start , this is the drill:

push start button without your foot on the brake
I scroll down to see the oil life gauge
press the right arrow and the start button simultaneously
pump the gas pedal three times
press the right arrow to get the reset option. it comes up cancel, push the down arrow to get confirm
press the right arrow again to confirm
---> it then resets , voila .
""
 
1 - 4 of 4 Posts
Top