RAM 1500 Diesel Forum banner
21 - 31 of 31 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter · #22 ·
P0299 gets set when the turbo underboosts at 4psi. the question is why the turbo is under boosting which both a long and distinquished list of tests. the other codes can be helpful but get some flights (telemtry) on systems to see if 2 & 4 are over dueling for example.
I just realized that I misquoted a previous response intended for you. If I could trouble you to take a look at post #18, my questions were actually directed to you, rather than the quote I put on there.
 

·
Premium Member
Joined
·
623 Posts
Can I ask you to dumb this down a little for me. What exactly am I supposed to be looking at? I don’t follow “2 & 4 are over dueling” maybe you meant cylinders 2 and 4 are over fueling? But even if that is correct, how do I look at that? Please, if possible, simplify the process as if you’re explaining it to someone who knows almost nothing about it. I’m trying to figure out which data I need to be looking at for answers.

As a secondary note, I threw a new MAP sensor at it. Set off the code the next morning getting on the highway. So no go there.
yeah I said 2 and 4 for brevity on my phone, but a tech can run a flight and plot the fueling for each cyclinder and they should all be similar, typically 2 &4 for whatever reason Ive read seem to get more carbon and they foul up the rings which can cause reduced compression and therefore over fueling.

0299 is barely better than idiot light to be honest. the laymans translation is that “the pressure on the turbo side of intake is under 4psi, good luck!”. lol

my swirl valves are working perfectly at 80k and the tech was shocked. if you have low soot, now intake leaks, a good alternator and battery its probably the turbo or a sensor
 

·
Registered
Joined
·
62 Posts
Discussion Starter · #24 ·
yeah I said 2 and 4 for brevity on my phone, but a tech can run a flight and plot the fueling for each cyclinder and they should all be similar, typically 2 &4 for whatever reason Ive read seem to get more carbon and they foul up the rings which can cause reduced compression and therefore over fueling.

0299 is barely better than idiot light to be honest. the laymans translation is that “the pressure on the turbo side of intake is under 4psi, good luck!”. lol

my swirl valves are working perfectly at 80k and the tech was shocked. if you have low soot, now intake leaks, a good alternator and battery its probably the turbo or a sensor
I’ll have to see if my buddy can bring the scanner by this weekend. I don’t think any of what I have will log that info.

I’ve got no idea if the intake is soot filled or the valves work or don’t. I can only say that I didn’t see any obvious leaks area with my smoke machine hooked up. How difficult is pulling the intake manifold? Is it worth yanking it off the truck and trying to clean it up? I’m only seeing some super cheap looking ones on eBay and Banks ones for $7-900 So I don’t think intake getting replaced as a ”maintenance” item is going to happen.
 

·
Registered
Joined
·
31 Posts
On all my past turbodiesels, a P0299 code is always an underboost condition. This can be from many things: from a blown hose, to a stuck wastegate controller or actuator, to a blown turbo. You need to find a way to inspect everything in the pathway of the air going to the intake: exhaust manifold to turbo, turbo itself (including variable vane system and wastegate controller and actuator), any boost pipes/hoses before/after the intercooler. Maybe run a smoke test for longer to see where the leak(s) is.

In the end, it will be limited to a boost leak somewhere, a physical fault with the wastegate controller or actuator, a bad sensor, or the turbo has just shat itself. But if that were the case, you'd likely have experienced more than just limp mode; you'd have black/blue smoke out the exhaust, or could've had a runaway condition. Since you mentioned nothing else other than limp mode, I'm guessing it's a boost leak somewhere and the ECU isn't happy until it's fixed.
 

·
Registered
Joined
·
2,511 Posts
On all my past turbodiesels, a P0299 code is always an underboost condition. This can be from many things: from a blown hose, to a stuck wastegate controller or actuator, to a blown turbo. You need to find a way to inspect everything in the pathway of the air going to the intake: exhaust manifold to turbo, turbo itself (including variable vane system and wastegate controller and actuator), any boost pipes/hoses before/after the intercooler. Maybe run a smoke test for longer to see where the leak(s) is.

In the end, it will be limited to a boost leak somewhere, a physical fault with the wastegate controller or actuator, a bad sensor, or the turbo has just shat itself. But if that were the case, you'd likely have experienced more than just limp mode; you'd have black/blue smoke out the exhaust, or could've had a runaway condition. Since you mentioned nothing else other than limp mode, I'm guessing it's a boost leak somewhere and the ECU isn't happy until it's fixed.
Hi: Dr_Dr3i... Sounds just like my wife!!!
Dieseldragon North shore of Lake Erie.
 

·
Registered
Joined
·
62 Posts
Discussion Starter · #27 ·
On all my past turbodiesels, a P0299 code is always an underboost condition. This can be from many things: from a blown hose, to a stuck wastegate controller or actuator, to a blown turbo. You need to find a way to inspect everything in the pathway of the air going to the intake: exhaust manifold to turbo, turbo itself (including variable vane system and wastegate controller and actuator), any boost pipes/hoses before/after the intercooler. Maybe run a smoke test for longer to see where the leak(s) is.

In the end, it will be limited to a boost leak somewhere, a physical fault with the wastegate controller or actuator, a bad sensor, or the turbo has just shat itself. But if that were the case, you'd likely have experienced more than just limp mode; you'd have black/blue smoke out the exhaust, or could've had a runaway condition. Since you mentioned nothing else other than limp mode, I'm guessing it's a boost leak somewhere and the ECU isn't happy until it's fixed.
Maybe I didn’t let the smoke run long enough when testing. I really expected it to billow out of the intake manifold and when it didn’t, I was actually a little disheartened because that would have at least been an answer. I’d definitely prefer a boost leak somewhere to the turbo being bad. I’m just not positive about either since that sort of failure isn’t really intermittent like the problem seems to be. Worries me that it could possibly electrical.
 

·
Premium Member
Joined
·
623 Posts
the air intake is a flimsy pos and the comnection behind the engine cover looked loose on mine orob from when they did the egr cooler. when its really hot the hoses get pliable and thinks will be more probe to leak hot then cold. the intercooler hose clamps for the turbo and intercooler connections are laughable, the clamps dont ecen clamp at all, they are just suppose to keep the hose against a pipe boss fitting and notoriously leak. its the shittiest clamp design ever invented. zip ties would work better.
 

·
Registered
2017 Ram 1500 ED Laramie 4x4 3.92 Charlotte, NC
Joined
·
1,706 Posts
I've been putting this out there on other posts, but there is a recall/software update for P0229 and P20EE. It's covered under TSBS 18-068-20 rev 2. Not sure how that will work with your original GDE tune though.
 

·
Registered
Joined
·
62 Posts
Discussion Starter · #30 ·
Dropping an update to say I don’t have anything figured out. I have tested more, logged but can’t get the data off the scanner due to it being too large of a file size to send. I’ve pushed the truck hard and can feel a lack of boost compared to what it should be. I haven’t replaced anything else other than the MAP sensor, air filter and the battery.

At this point I’m guessing its the turbo. So I’m trying to save up for buying a two post lift so that I can lift the cab and replace it.

Anyone ever swap this drivetrain out for a more reliable/more powerful one? 12 valve? LS - lol? Seriously, I don’t hate the body of the truck I’ve got, but I’ve been nothing but disappointed by the ecodiesel for years now. I tried trading it in, but dealers don’t even want it without giving me pennies on the dollar. Said they have a hard time getting rid of them. I’m too far upside down to do anything other than keep driving this turd at this point.
 

·
Registered
Joined
·
12 Posts
I have had issues with the p0299 code and have posted about it on here in the past. Reset the code at least 10 times. I put a new MAP sensor in and had a code soon after. Since then it has been close to a year and close to 15,000 miles without a code. I don’t think the problem is fixed but I have learned what causes the under boost and I try to avoid it. For me It only happens under a load such as going up a hill soon after the truck has been sitting And I can climb the hill slowly without giving much throttle and let the truck work. Once it shifts and I hear the turbo spool I don’t have an issue. my truck is also deleted and tuned, but i bought it that way and have no idea what tune it has or if that is causing the problem. I know this doesn’t help you any, but I feel your pain as I don’t trust my truck not to leave me stranded in the mountains somewhere. In a way I keeps me from doing things I want to do.
 
21 - 31 of 31 Posts
Top