RAM 1500 Diesel Forum banner

61 - 63 of 63 Posts

·
Registered
Joined
·
73 Posts
I had one regen (evic) my first 45,000 miles. Since the AEM I have had 11 regens in 4000 miles. All these regens happened after long drives on freeway and after I stopped and restarted. Should not have been seen driving 65MPH on freeways. I got the message with out any alarm tone. "regen in progress continue driving until complete"
 

·
Registered
Joined
·
6 Posts
I had the AEM done and noticed no immediate problems but now I have a check engine lite. P050E which says the exhaust does not heat up fast enough on cold starts. I have monitored it a bit and all the sensors seem to be working correctly. Local dealer wants $140 to scan and see what to do. They really stuttered when I said FCA gave an extended warranty on the engine components with the settlement. Guess I will find out Monday.
 

·
Administrator
Joined
·
8,296 Posts
I had the AEM done and noticed no immediate problems but now I have a check engine lite. P050E which says the exhaust does not heat up fast enough on cold starts. I have monitored it a bit and all the sensors seem to be working correctly. Local dealer wants $140 to scan and see what to do. They really stuttered when I said FCA gave an extended warranty on the engine components with the settlement. Guess I will find out Monday.
Be sure to remind your dealer that the warranty states:

"• Additionally, the Extended Warranty shall cover the cost of any OBD Diagnostic Scan for malfunctions that trigger the OBD Malfunction Indicator Light (MIL), regardless of whether the malfunction is attributable to a part that is covered under the Extended Warranty."
 
61 - 63 of 63 Posts
Top