RAM 1500 Diesel Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a issue with my 2016 Eco-diesel. I lost acceleration at points in my driving and then got a message " Service Electronic Throttle Control " I have 113000 km on my vehicle so warranty is up by 13000 km. Dealership said it was going to be a $4800.00 fix. Contacted Dodge to see if they could do anything of coarse the answer was "NO". Even though the soot must have been building up before the light came on. I would like to know how many people this has happened to. This should be a recall cause it is a safety concern if your vehicle fails to accelerate in an intersection this could become a deadly situation.

If you have gotten the "Service Electronic Throttle Control" or are starting to lose power while driving please comment
 

·
Registered
Joined
·
479 Posts
All you have to do is search and read this forum or google it. Hundreds of posts about this issue. P0299 code is most common. The "Service Electronic Throttle Control" is like having a headache but then finding out you have brain cancer and have a week to live.
 

·
Registered
Joined
·
545 Posts
You can search for my posts - there have been a few. Ended up being the Accelerator Pedal. It is drive by wire - started sending the wrong data to the ECM. So what was "limp" mode was actually the Pedal not responding properly, which generated a number of error codes, etc.

There was nothing wrong with the Engine. Once the pedal was replaced, it has not happened again. I have a 2014 with 100K.
 

·
Registered
Joined
·
2,217 Posts
My truck had this issue. Kind of. Mine's symptom was that when coming to a stop, the engine would die. But it would immediately re-start and run fine. Check engine light would illuminate, but then it would eventually go away. This happened 3 or 4 times.

Then my battery died. Since I've put the new battery in, it stopped. So my conclusion is that the circuit was somehow affected by my battery going through its throes of dying over a long period of time. These days one must have lots of electricity to support all of the electronics in their vehicles.
 

·
Registered
Joined
·
5 Posts
I had this last week, 2015 Eco with 95,000 miles, still in the shop but they called yesterday and the PCM is out. No warranty of course but in the FCA settlement the PCM will receive an updated warranty. I am going to contact FCA to try and get them to cover it anyway.
 

·
Registered
Joined
·
479 Posts
This is a common code that gets thrown with the DPF 100 full
Well, is it throwing the code because the DPF is full or is it not running correctly and therefore the DPF is full. They put a new DPF on mine and it still threw that warning. So just to say that this code is thrown when the DPF is full is not correct.

I had this last week, 2015 Eco with 95,000 miles, still in the shop but they called yesterday and the PCM is out. No warranty of course but in the FCA settlement the PCM will receive an updated warranty. I am going to contact FCA to try and get them to cover it anyway.
I call BS on this. Sounds like the dealer efffed it up and are trying to cover their butts. First time on this forum that I have heard of a dealer telling the customer that his PCM/ECM is faulty.

Read this.... https://www.ram1500diesel.com/forum/ram-1500-diesel-general-discussion/59744-2015-ecodiesel-debacle-demonic-proportions-p0299-p026d-p2459-codes.html
 

·
Registered
Joined
·
5 Posts
Thanks for the info, when i shut if off no restart. Waited half-hour for tow truck and tried again still no restart, not sure what to do about the dealer but will have conversation with them Monday. They sounded surprised it was out and tech asked for permission to make sure not something else. Came back and said the unit was bad, sucks because the engine has been flawless from day one. My only issue was a leak it took them two tries to fix just after i bought it and the parking sensors go off when you slow down in the rain. FCA refused to replace because they worked--really, and intermittent cruise failing to set, when it does a little bank on the control area and it works perfect. Other than that just routine maintenance and it spent 3 years running around on coal mine roads. GDE is going to happen quickly when i get it back, especially if they have done the new flash.
 

·
Registered
Joined
·
13 Posts
I have had that code and message I think it can happen if you hit the brake with foot on gas like rocking out of being stuck in snow.. Mine went away no issues. Ill take a good old throttle cable over some electronic junk anyday
 

·
Registered
Joined
·
23 Posts
I have a 2016 ed with 47000 miles and the electronic throttle control popped up yesterday. I couldn't drive past 40 mph. Luckily I was near a dealership and left it there. I will update everyone when they diagnose it.

Got me thinking with all these post if it's time to trade her in or am I over reacting?
 

·
Registered
Joined
·
479 Posts
I have a 2016 ed with 47000 miles and the electronic throttle control popped up yesterday. I couldn't drive past 40 mph. Luckily I was near a dealership and left it there. I will update everyone when they diagnose it.

Got me thinking with all these post if it's time to trade her in or am I over reacting?
Depends. See what the dealer says. Hopefully you still have a warranty. You don't have that many miles on it.

After talking to GDE numerous times they said that their tune would take care of virtually all of these nuisance codes. They were correct. Been driving mine now for nearly 9 months with no issues after installing GDE.
 

·
Registered
Joined
·
23 Posts
I have a 2016 ed with 47000 miles and the electronic throttle control popped up yesterday. I couldn't drive past 40 mph. Luckily I was near a dealership and left it there. I will update everyone when they diagnose it.

Got me thinking with all these post if it's time to trade her in or am I over reacting?
Depends. See what the dealer says. Hopefully you still have a warranty. You don't have that many miles on it.

After talking to GDE numerous times they said that their tune would take care of virtually all of these nuisance codes. They were correct. Been driving mine now for nearly 9 months with no issues after installing GDE.
Dealer said it was the EGR and it's under warranty. Theyre fixing it at no charge. Hopefully that takes care of the problem. I wonder if this has anything to do with lawsuit against FCA emissions?
 

·
Registered
Joined
·
23 Posts
ETC check engine light repairs. Egr cooler leaking coolant internally & into intake manifold. Warranty covered replacing cooler egr valve, intake manifold, fuel supply tube kit. My truck was down for 5 days. Picked it up and the next day check engine light on again. Scheduled to go back in next week, round two. I have 47000 easy miles, I don't tow, I drive between 70-75 in shorr this is my baby. I'll keep you guys posted.
 

·
Registered
Joined
·
627 Posts
The responses here are a touch scary. It appears some of the dealer techs have the training of a lab rat and nearly zero skill at diagnosing a real problem.

ETC check engine light repairs. Egr cooler leaking coolant internally & into intake manifold. Warranty covered replacing cooler egr valve, intake manifold, fuel supply tube kit. My truck was down for 5 days. Picked it up and the next day check engine light on again. Scheduled to go back in next week, round two. I have 47000 easy miles, I don't tow, I drive between 70-75 in shorr this is my baby. I'll keep you guys posted.
By the way, don't baby that truck too much. Spool that turbo once and a while. It will also help to get some type of monitor so you know when it is in REGEN mode and can choose to run it out.

Personally, I'm waiting on the snow to melt so I can put my trailer behind mine and climb the biggest hill I can find. :cool:
 

·
Registered
Joined
·
23 Posts
Update, 2nd time in for service because of the check engine light. They advised it was a speed switch and replaced it cost me $325. As I'm driving home the check engine light came on again. Took it back the next day and they advised its a diesel sensor harness and its on order, smh. Cant wait till they fix that so the check engine light comes on again with another problem 🤔
 

·
Registered
Joined
·
23 Posts
The responses here are a touch scary. It appears some of the dealer techs have the training of a lab rat and nearly zero skill at diagnosing a real problem.

ETC check engine light repairs. Egr cooler leaking coolant internally & into intake manifold. Warranty covered replacing cooler egr valve, intake manifold, fuel supply tube kit. My truck was down for 5 days. Picked it up and the next day check engine light on again. Scheduled to go back in next week, round two. I have 47000 easy miles, I don't tow, I drive between 70-75 in shorr this is my baby. I'll keep you guys posted.
By the way, don't baby that truck too much. Spool that turbo once and a while. It will also help to get some type of monitor so you know when it is in REGEN mode and can choose to run it out.

Personally, I'm waiting on the snow to melt so I can put my trailer behind mine and climb the biggest hill I can find. <img src="http://www.ram1500diesel.com/forum/images/smilies/cool.png" border="0" alt="" title="Cool" class="inlineimg" />
Roger that and thanks for the advice.
 

·
Registered
Joined
·
64 Posts
I have a issue with my 2016 Eco-diesel. I lost acceleration at points in my driving and then got a message " Service Electronic Throttle Control " I have 113000 km on my vehicle so warranty is up by 13000 km. Dealership said it was going to be a $4800.00 fix. Contacted Dodge to see if they could do anything of coarse the answer was "NO". Even though the soot must have been building up before the light came on. I would like to know how many people this has happened to. This should be a recall cause it is a safety concern if your vehicle fails to accelerate in an intersection this could become a deadly situation.

If you have gotten the "Service Electronic Throttle Control" or are starting to lose power while driving please comment
I've got the same problem and engine light at 75000 km. Engine went into default mode and wouldn't Rev above 2500 RPMs. I have removed and cleaned the MAP sensor and deleted engine fault and everything was fine again.
 

·
Registered
Joined
·
479 Posts
I've got the same problem and engine light at 75000 km. Engine went into default mode and wouldn't Rev above 2500 RPMs. I have removed and cleaned the MAP sensor and deleted engine fault and everything was fine again.
Give it a week or less. The light will come back on. I removed and cleaned mine. Lasted a day or two. Did it again. Same story. Purchased a new MAP sensor. Drove about 6 miles and light reappeared.
What was the eventual fix you might ask? $9000 in parts and eventually a GDE tune to make it work.
 

·
Registered
Joined
·
2,217 Posts
My truck had this issue. Kind of. Mine's symptom was that when coming to a stop, the engine would die. But it would immediately re-start and run fine. Check engine light would illuminate, but then it would eventually go away. This happened 3 or 4 times.

Then my battery died. Since I've put the new battery in, it stopped. So my conclusion is that the circuit was somehow affected by my battery going through its throes of dying over a long period of time. These days one must have lots of electricity to support all of the electronics in their vehicles.
It's the battree I tell ya!
 

·
Registered
Joined
·
64 Posts
I've got the same problem and engine light at 75000 km. Engine went into default mode and wouldn't Rev above 2500 RPMs. I have removed and cleaned the MAP sensor and deleted engine fault and everything was fine again.
Give it a week or less. The light will come back on. I removed and cleaned mine. Lasted a day or two. Did it again. Same story. Purchased a new MAP sensor. Drove about 6 miles and light reappeared.
What was the eventual fix you might ask? $9000 in parts and eventually a GDE tune to make it work.
So far it worked. It's been 5 months now and around 8000km (5000mi). Also cleaned EGR tube last month for the first time. It was dirty and messy.
 
1 - 20 of 26 Posts
Top