RAM 1500 Diesel Forum banner

41 - 60 of 66 Posts

·
Registered
Joined
·
744 Posts
I know they are in Manitoba, just don't know where for sure. Been almost 50 years since I lived there. Was born and raised there.
 

·
Registered
Joined
·
2,017 Posts
I have the same issue. Service ETTC, but only when the truck warms up or under braking.
Ok, long story short. I had a Diesel "Specialist" do a delete because of problems with the EGR. FIrst, he sent my ECM for reprogramming. He told me it was GDE tuned. Come to find out, GDE hasn't been performing tunes since months before mine had been done. I know it was tuned, just not by GDE because of contacting GDE and asking if my VIN had gone through their system. Now, I have found this forum. The diesel "Specialist" did nothing else and my '17 Ecodiesel is now going into limp mode when warm or under braking. I had it diagnosed by several other places, replacing components that did not fix the problem. Now I am pointing to the tune, because it only started after the ECM reprogramming. The EGR was not removed, but the tune was supposed to disable the EGR. The truck has had the exhaust installed to delete the DPF. I desperately need a repair tune done, this bench tuning is driving me crazy. Any recommendations? It runs properly(with GREAT power) before heated up and on the freeway with very little deceleration or braking.
Your diesel specialist is an idiot and sold you a cheap tune. Im sure he used a certain tuner that I wont name but either way you should demand a refund and get a proper tune from somewhere else. Or demand they tell you who actually made the tune and get support from them.
 

·
Registered
Joined
·
3 Posts
Thank you both for your input. It is greatly appreciated. I have never dealt with the person before, and would not have if I had not had an issue with the EGR. I was between a rock and a hard place.
 

·
Registered
Joined
·
2 Posts
I have a issue with my 2016 Eco-diesel. I lost acceleration at points in my driving and then got a message " Service Electronic Throttle Control " I have 113000 km on my vehicle so warranty is up by 13000 km. Dealership said it was going to be a $4800.00 fix. Contacted Dodge to see if they could do anything of coarse the answer was "NO". Even though the soot must have been building up before the light came on. I would like to know how many people this has happened to. This should be a recall cause it is a safety concern if your vehicle fails to accelerate in an intersection this could become a deadly situation.

If you have gotten the "Service Electronic Throttle Control" or are starting to lose power while driving please comment
 

·
Registered
Joined
·
2 Posts
I have a issue with my 2016 Eco-diesel. I lost acceleration at points in my driving and then got a message " Service Electronic Throttle Control " I have 113000 km on my vehicle so warranty is up by 13000 km. Dealership said it was going to be a $4800.00 fix. Contacted Dodge to see if they could do anything of coarse the answer was "NO". Even though the soot must have been building up before the light came on. I would like to know how many people this has happened to. This should be a recall cause it is a safety concern if your vehicle fails to accelerate in an intersection this could become a deadly situation.

If you have gotten the "Service Electronic Throttle Control" or are starting to lose power while driving please comment
I joined this forum just to reply to your issue. My truck is currently at my dealer for repair for the second time for this issue. No word so far. I agree the hesitation when you need acceleration is extremely dangerous.
Never have posted any of my issues on my 2018 truck, but I plan to request my service record and post it soon. I recently asked Ram if they could help me since I obviously have a problem truck. I have had numerous sensor issues since the engine had to be replaced at 10,000 miles. Ram told me they will not help and sent me the arbitration number. I am at my dealer so often they know me by name at the truck center.
 

·
Registered
Joined
·
19 Posts
just purchased less then a week ago a new 2020 Ram 1500 EcoDiesel Limited with the Towing package. While towing a travel trailer, approx. 6100 Lbs for about 4 hours, mainly on the highway with varying grades, without any issues, the
Service Electronic Throttle light came on. My power was cut about 60% and I limped into Paso Robles that night. I went to the Ram Dealer, who cleared the codes, but couldn't find any issues. My Ram was running fine that morning, but still had the message and check engine light on. The Dealer couldn't do anything. While traveling home, about 3 hours into our trip home, and after going up the I-5 Grapevine (step long hill) without any issues, the Service Electronic Throttle light came back on, and back to only having 40% power. I limped into a Ram Dealer in Los Angeles. The Service Dept was closed. I disconnected the battery, reconnected it. The Service Electronic Throttle light was off, only the check engine lite was on. I continued our travel home. about an hour into our travel, the Service Electronic Throttle light came back on, loss of power again, pulled into a rest area. turned off the Ram, about 30 minutes later, turned on the Ram and the Service Electronic Throttle light was off. We headed for another 2 hours home, arriving without any issues. The next morning, out of trailer mode, the Service Electronic Throttle light is not there and the check engine light is not showing either. The truck is running fine without towing our travel trailer. Will be dropping off our Ram tomorrow as we don't want to have this issue while towing our trailer and going up a steep grade, which could be tragic. Hopefully they can repair this or take the Ram back due to the Lemon Law. Thought I would post this, as I didn't see any 2020's and appears still to be an issue. You would think by now, this would be corrected based on the number of posts and the ages of the Rams having this issue.
 

·
Registered
Joined
·
19 Posts
just purchased less then a week ago a new 2020 Ram 1500 EcoDiesel Limited with the Towing package. While towing a travel trailer, approx. 6100 Lbs for about 4 hours, mainly on the highway with varying grades, without any issues, the
Service Electronic Throttle light came on. My power was cut about 60% and I limped into Paso Robles that night. I went to the Ram Dealer, who cleared the codes, but couldn't find any issues. My Ram was running fine that morning, but still had the message and check engine light on. The Dealer couldn't do anything. While traveling home, about 3 hours into our trip home, and after going up the I-5 Grapevine (step long hill) without any issues, the Service Electronic Throttle light came back on, and back to only having 40% power. I limped into a Ram Dealer in Los Angeles. The Service Dept was closed. I disconnected the battery, reconnected it. The Service Electronic Throttle light was off, only the check engine lite was on. I continued our travel home. about an hour into our travel, the Service Electronic Throttle light came back on, loss of power again, pulled into a rest area. turned off the Ram, about 30 minutes later, turned on the Ram and the Service Electronic Throttle light was off. We headed for another 2 hours home, arriving without any issues. The next morning, out of trailer mode, the Service Electronic Throttle light is not there and the check engine light is not showing either. The truck is running fine without towing our travel trailer. Will be dropping off our Ram tomorrow as we don't want to have this issue while towing our trailer and going up a steep grade, which could be tragic. Hopefully they can repair this or take the Ram back due to the Lemon Law. Thought I would post this, as I didn't see any 2020's and appears still to be an issue. You would think by now, this would be corrected based on the number of posts and the ages of the Rams having this issue.
 

·
Registered
Joined
·
19 Posts
Ram dealer, given the history of our Service Throttle light while towing our travel trailer states that it’s the MAP Sensor is faulty and is on order (7 days) to be replaced. Hopeful that this works. My 2020 Ram is 10 days old. The problem only presents itself when towing, under Trailer/Tow mode, and so far on level grade and can occur after 4 hours of towing or an hour of towing.... thank God it didn’t occur while going up a very steep grade.... will keep this updated.
 

·
Registered
Joined
·
19 Posts
Forgot to mention while at the first Ram dealer is Paso Robles, they found two codes: P00AF Turbo Module Performance and P26FB EGR Cooler Bypass control stuck closed Bank 1- Found star case S2018000001 for EGR code. . . .possible future software flash for codes.

note sure what this all means. Just hoping the MAP Sensor replacement is all that is needed.
 

·
Registered
Joined
·
2 Posts
I have a issue with my 2016 Eco-diesel. I lost acceleration at points in my driving and then got a message " Service Electronic Throttle Control " I have 113000 km on my vehicle so warranty is up by 13000 km. Dealership said it was going to be a $4800.00 fix. Contacted Dodge to see if they could do anything of coarse the answer was "NO". Even though the soot must have been building up before the light came on. I would like to know how many people this has happened to. This should be a recall cause it is a safety concern if your vehicle fails to accelerate in an intersection this could become a deadly situation.

If you have gotten the "Service Electronic Throttle Control" or are starting to lose power while driving please comment
This just happened to my 2019 with 170miles on it. Only went through a quarter tank of fuel. Not a good start.
 

·
Registered
Joined
·
28 Posts
Ram dealer, given the history of our Service Throttle light while towing our travel trailer states that it’s the MAP Sensor is faulty and is on order (7 days) to be replaced. Hopeful that this works. My 2020 Ram is 10 days old. The problem only presents itself when towing, under Trailer/Tow mode, and so far on level grade and can occur after 4 hours of towing or an hour of towing.... thank God it didn’t occur while going up a very steep grade.... will keep this updated.
I sincerely apologize for the trouble, @RamDog. Please be sure to keep us posted on your situation. If you are in need of any additional support while working with your dealer or if they experience a part delay, I am more than happy to escalate a case on your behalf for further support. Our team is just a private message away.

Mark
RamCares
 

·
Registered
Joined
·
19 Posts
I sincerely apologize for the trouble, @RamDog. Please be sure to keep us posted on your situation. If you are in need of any additional support while working with your dealer or if they experience a part delay, I am more than happy to escalate a case on your behalf for further support. Our team is just a private message away.

Mark
RamCares
Thank you for your email. I love my Ram, bought it on July 4th, in the Ram Dealership all day on July 10th. Now at the Ram Dealership in Poway CA since July 12th for 8 days or more. Unfortunately it will be in the Shop more then days I have been able to drive it.

It’s a 2020 Ram 1500 Limited w a tow package. The last 5 of the vin is 51132

the Service Advisor Thinh seems knowledgeable and hopefully it’s just the MAP sensor, but from all of the posts is seems to be the EGR Control panel itself. Worried that we might have an issue on our next vacation towing our ultra light trailer and having a Service Electronic Throttle light come on, have a loss of power, while going up a long steep grade and causing an accident with injuries or worse. That is my biggest fear. I’m sure Ram Cares, and wants to make sure nothing like that ever happens. Thank you for reaching out. It’s appreciated. Glenn
 

·
Registered
Joined
·
28 Posts
Thank you for your email. I love my Ram, bought it on July 4th, in the Ram Dealership all day on July 10th. Now at the Ram Dealership in Poway CA since July 12th for 8 days or more. Unfortunately it will be in the Shop more then days I have been able to drive it.

It’s a 2020 Ram 1500 Limited w a tow package. The last 5 of the vin is 51132

the Service Advisor Thinh seems knowledgeable and hopefully it’s just the MAP sensor, but from all of the posts is seems to be the EGR Control panel itself. Worried that we might have an issue on our next vacation towing our ultra light trailer and having a Service Electronic Throttle light come on, have a loss of power, while going up a long steep grade and causing an accident with injuries or worse. That is my biggest fear. I’m sure Ram Cares, and wants to make sure nothing like that ever happens. Thank you for reaching out. It’s appreciated. Glenn
Thank you very much for taking the time to keep me posted, @RamDog. I certainly understand your sentiments and we'd like to do all we can to ensure that you have proper support in getting this handled. We are just a private message away if you are interested in having a case escalated for further support!

Mark
RamCares
 

·
Registered
Joined
·
1 Posts
You can search for my posts - there have been a few. Ended up being the Accelerator Pedal. It is drive by wire - started sending the wrong data to the ECM. So what was "limp" mode was actually the Pedal not responding properly, which generated a number of error codes, etc.

There was nothing wrong with the Engine. Once the pedal was replaced, it has not happened again. I have a 2014 with 100K.
I HAVE this issue right now I almost rear ended the car in front of me because my truck 2016 dodge ram decided to accelerate on its one. Scared the crap out of me then it would not accelerate stayed at 40mph with my foot to the floor. Anyone have the part number for the pedal i need to get??
 

·
Registered
Joined
·
19 Posts
I HAVE this issue right now I almost rear ended the car in front of me because my truck 2016 dodge ram decided to accelerate on its one. Scared the crap out of me then it would not accelerate stayed at 40mph with my foot to the floor. Anyone have the part number for the pedal i need to get??
Wow pretty scary stuff. Sorry you experienced that and glad no injuries or damages.
 

·
Registered
Joined
·
19 Posts
Update on my 2020 RAM. Just told by RAM that in addition to the MAP sensor being replaced they are also replacing the EGR cooler and should have my truck back on Friday. It’s brand new, just bought it on July 4th, and it’s been in the shop 50% of the time if owned it. Hopefully this solves it, but a little worried that I bought a lemon
 

·
Registered
Joined
·
21 Posts
RamDog/Glenn,
I've had the EGR Cooler replaced twice on my 2016 Limited with towing package, the most recent was last week. When you pick your truck up, ask to see the cooler they removed and take a picture of the label that has the manufacture date and part info. It would be a shame if the 2020s have been built with the old model cooler that is being replaced nationwide with ones built in the last few months.
Bill
 

·
Registered
Joined
·
19 Posts
RamDog/Glenn,
I've had the EGR Cooler replaced twice on my 2016 Limited with towing package, the most recent was last week. When you pick your truck up, ask to see the cooler they removed and take a picture of the label that has the manufacture date and part info. It would be a shame if the 2020s have been built with the old model cooler that is being replaced nationwide with ones built in the last few months.
Bill
I’ll ask for it. Will let you know what I find out
 

·
Registered
Joined
·
28 Posts
I HAVE this issue right now I almost rear ended the car in front of me because my truck 2016 dodge ram decided to accelerate on its one. Scared the crap out of me then it would not accelerate stayed at 40mph with my foot to the floor. Anyone have the part number for the pedal i need to get??
I sincerely regret to hear of your trouble, @talltanya061079. We kindly recommend following up with our Canadian Customer Care team for further support. You may either call 1-800-361-3700 or submit your info at Contact Us - FCA Canada to receive an email follow up.

Update on my 2020 RAM. Just told by RAM that in addition to the MAP sensor being replaced they are also replacing the EGR cooler and should have my truck back on Friday. It’s brand new, just bought it on July 4th, and it’s been in the shop 50% of the time if owned it. Hopefully this solves it, but a little worried that I bought a lemon
Just had a chance to respond to your message, @RamDog!

Mark
RamCares
 
41 - 60 of 66 Posts
Top