RAM 1500 Diesel Forum banner
1 - 2 of 2 Posts

· Registered
23 Posts
Discussion Starter · #1 ·
had this error pop up saturday afternoon leaving the house, no check engine light, no codes, just SETC error. ill try to make this short as possible....
2016 laramie 4x4 bought used 4/2019 with 90k miles. in jan 2020 i did full delete with SFT stage 2 tune, straight pipe, etc.. been basically trouble free now at 170,000mi. until this service electronic throttle control...

i get to checking intake, connections to turbo, to intercooler, to throttle valve. check harness under the dash, harness under the cab inside the frame rail. made sure the plate in the throttle valve rotated by hand, tried pedal reset (turn on but not running, slowly press pedal to floor then slowly release) could not find anything wrong. found a post where someone said they removed the plate in the throttle valve and it fixed their issue. i tried that to no resolve. then came across a post by user Adi here P0234 and SETC Issues that i cannot figure out. so i did as he detailed and removed the link arm from the actuator on the turbo and the link arm moved up/down freely but the actuator did not, it was in the down position if i recall correctly. had my son start the truck with the link disconnected and the actuator didnt move. i pried on it a bit with a screwdriver and it moved a little so i had him shut it down. put everything back together and at this point i had check engine lights and codes since we started it without the air intake attached. cleared codes and had him put it in run but not start the motor and the actuator moved as normal. went ahead and started the truck and all codes and SETC gone. ran the truck around for 5-10mins up to 45mph with no issue so i moved to bigger roads up to 70mph for 10min, then back on the slower roads for 5-10mins. and no codes or SETC came back. hope it jarred loose or re-seated whatever is needed to keep this thing running! it seems like everyone thats had this issue has posted a different way to a resolution so i figured i should add to the mess in case it can help anyone else out.
1 - 2 of 2 Posts