RAM 1500 Diesel Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1,291 Posts
Discussion Starter · #1 ·
sigh. cruising home today and up popped the EVIC ghosts "service air suspension, service trailer brake system, service electronic brake system, service shifter" along with the traction control warning light on the dash. this is same symptom that had me bring in to the dealer 2 weeks ago (along with the air suspension activity). took my screen shots with my phone... i really do like my truck, love driving it. i do not like that at 2K miles i'm now going to go back to the dealer AGAIN... i think the real problem for me is the traction control light because if that is light solid (amber) doesn't that mean it is not functioning/off?

the other service messages might not be a big deal, but if the traction control system is being disabled while driving, that bugs me big time...

has anyone else run into those EVIC messages? i am not alone (again) as on the "other ram forum" there is a similar thread and it is not with the ED.
 

·
Registered
Joined
·
1,532 Posts
It'll get straightened out, we all took a risk with the first model year. Still sucks, but that's the cost of the ticket to the dance to be the first ones with it.
 

·
Registered
Joined
·
334 Posts
Mine has come up saying service air suspension, service electronic brake system but only when my obd2 adapter is plugged in. My traction control light also stayed on and my cruise control did not work. I have driven probably 5500 miles without the adapter and have not seen the warnings and only 1000 miles with it plugged in and have seen it about 10 times. Best of luck getting it figured out it has to be a communication issue between the modules on the truck.
 

·
Registered
Joined
·
1,337 Posts
Jeff just for fun check that plug up in the frame another member had come apart on him!
 
1 - 5 of 5 Posts
Top