RAM 1500 Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
Anyone else getting the following messages on startup? Oil Pressure Low and Low fuel in the range display? Clearly from the pictures, I had a full tank of fuel...That doesn't concern me as much as Oil Pressure low...The fuel low happens every startup then goes away. the Oil Pressure Low is radom. Dealer thinks that I need a flash update...I thinks it's more than that. Thanks for your responses. JDK
IMG_2880.PNG IMG_2878.PNG
 

·
Registered
Joined
·
704 Posts
As has been well documented on this forum, our ED's do not utilize an oil pressure sending unit. Rather, oil pressure is calculated using several inputs - the largest of which are temperature and rpm. If the ED use an oil pressure sending unit, I'd say that there is a possibility that somehow the signals were misinterpreted on the CANBUS and that a re-flash may cure that. In your case, I'd be skeptical if a simple re-flash would help.

That said, please be aware that your ED DOES have a pressure SWITCH. The oil pressure switch has a threshold of ~5-7psi. If oil pressure falls below this, you will get the light. Therefore, I would suggest that you may want to start with a re-flash but be ready to replace the oil pressure switch if the re-flash doesn't improve the situation.
 

·
Super Moderator
2015 Outdoorsman EcoD CC w/6.4' 4X4
Joined
·
4,856 Posts
I watched mine even after remote starting the truck, once I turned the ignition on, the oil pressure light in the EVIC turns red like there is a problem(does the same when just starting the truck).
It may just be a start-up test of the display, but I do have the 7" color EVIC.
 
1 - 4 of 4 Posts
Top