RAM 1500 Diesel Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi guys i am new to the forum and i must say you have been a wealth of information so far. I fall into a particularly strange grey area where i bought my 2015 Ecodiesel from a used car dealer here in florida, with out fully understanding what i was getting into. You see my truck was originally sold in Canada and the AEM was done in Canada last year. The truck was sold at auction in Florida, and now i realize that FCA USA, wont honor my warranty. So far i have had to replace 2 EGT sensors A Nox sensor and a O2 sensor, all parts that should have been under warranty. My question is i now have the dreaded service def see dealer 185 miles till truck will not start but with no cel . Has anyone else had this problem, and where do i start. I have the Alfaobd and OBDLINK MX+, and was a former mechanic so i am not affraid to get dirty.
 

·
Registered
Joined
·
365 Posts
Stupid question/suggestion, but your DEF tank isn't empty is it?

As @Ecosparky said, check the DEF nozzle first. Those are the only 2 things that might cause the mileage countdown without a cel.

Also make sure the DEF pump is working, turn the key to ON and listen for the pump to kick on. It may be hard to hear because the fuel pump is close by and typically louder, but the DEF tank (and pump) are right under the drivers seat. I think this would cause a cel, it can't hurt to check.

Also, check the flange between the DPF and SCR. the bolts are likely very rusty, and may look intact, but make sure they are not broken, and make sure the flange is tight (and the gasket is still there). If it's not, exhaust can leak out of the flange and melt the wiring for the DEF injector. If the wiring is melted it should definitely cause a cel though.

If all of that checks out, you may have to go to the dealer for more diagnostics. If you run out of miles on the countdown before you get to the dealer, there is a relay you can jumper out to start and drive the truck like normal despite having no miles left. There is a thread here somewhere that includes the procedure...
 

·
Registered
Joined
·
1,092 Posts
Hi guys i am new to the forum and i must say you have been a wealth of information so far. I fall into a particularly strange grey area where i bought my 2015 Ecodiesel from a used car dealer here in florida, with out fully understanding what i was getting into. You see my truck was originally sold in Canada and the AEM was done in Canada last year. The truck was sold at auction in Florida, and now i realize that FCA USA, wont honor my warranty. So far i have had to replace 2 EGT sensors A Nox sensor and a O2 sensor, all parts that should have been under warranty. My question is i now have the dreaded service def see dealer 185 miles till truck will not start but with no cel . Has anyone else had this problem, and where do i start. I have the Alfaobd and OBDLINK MX+, and was a former mechanic so i am not affraid to get dirty.
Hi: Superg... It's rough when your dream truck turns into a nightmare. I have one too. I've come to believe that most messages on the EVIC can be lies. This can be dangerous but most of mine have been so!!! One thing my dealer did do is clean off a lot of whiteish deposits from the DEF injector... at least they showed me a picture that they did!!! I'm still in Canada due to Co-Vivid but I'm out of warranty.
These trucks need a lot more attention than the sales people let on.
Dieseldragon North shore of Lake Erie.
 

·
Registered
Joined
·
1,433 Posts
Hi: Superg...
These trucks need a lot more attention than the sales people let on.
Dieseldragon North shore of Lake Erie.
Not really. I have 242,000 kms and have done nothing other than GDE hot tune, EGR delete, simple maintenance and brakes all done by me.
Dealer hasn't worked on my truck since they raped me for its first oil change.....oh and tailgate recall. The only recall thats been completed.
 

·
Registered
2015 RAM 1500 Ecodiesel
Joined
·
145 Posts
The exhaust flange leak is a common culprit. You def injector will be melted, if this is the issue.
 

·
Registered
Joined
·
977 Posts
You see my truck was originally sold in Canada and the AEM was done in Canada last year. The truck was sold at auction in Florida, and now i realize that FCA USA, wont honor my warranty.
Sorry for the hijack, but maybe for others benefit ....

I didn't know this until I traded my 2016 EcoD, but apparently a LOT of Canadian trucks are headed for the USA. There's some sort of a shortage down there? When I traded mine in a couple of weeks ago, I showed up to pick up my new Jeep GCherokee and as I handed in my keys the salesman told me my truck (which I got half of new for after 5 years and 90,000km) was already sold and headed for the states that day.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #10 ·
Check the def injector nozzle where its installed in the SCR to see if its clogged with crystallized def. Its an easy job and thats where I would start. Lots of posts here with pictures too.
Thanks for the rersponse The Def injector was cleaned, but was not clogged. i havent verified that the def gauge is functioning well, will try that today. going to add some fresh deff and check the level. Thanks
 

·
Registered
Joined
·
4,852 Posts
I think the gauge not working has been an issue in the past hopefully it is that simple for you.

If not before i spent money fixing costly emissions sensors etc. i would look into a delete tune.
 
1 - 12 of 12 Posts
Top