RAM 1500 Diesel Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi Gents-

for 3 days, everything worked as expected. Now, not so much.

I can connect my phone (LG G4) to the uConncect via bluetooth without issue - it can make a phone call, play music, or use Google Maps. However, it does not work when you try to do more than one at a time.

In the beginning... Connect phone, listen to music, launch google maps for directions. Music plays, music pauses while google navigation speaks, music resumes.
Now... Connect phone, listen to music, launch google maps for directions. Music plays, music pauses while google navigation __should be saying something. EXCEPT, google navigation is silent. Music resumes.

I deleted the phone from uConnect, deleted uConnect connection from phone, did soft uConnect reset, cleared cache of music player, and it started working again until i shut off truck. Now I am not able to fix it no matter what i do.

Same phone works as expected in my wife's minivan. Same phone works as expected with the $9 bluetooth speaker purchased on Amazon.

Per the worthless people on the end of the uConnect Assist button, RAM, FIAT, etc do not support 3rd party devices. Which is a really stupid statement as i am not aware of any RAM made cell phone and didn't know that RAM owned the Bluetooth protocol.

Anyone experience this? Any thoughts?

What i do not know:
- The current software version of my uConnect. How do i determine this?

2015 Big Horn EcoDiesel with 8.4 upgrade, Nav Ready (i save my $500)
Lg G4 running Android 5.1 stock. Not rooted or ROM'd

Thanks for your help.
 

·
Registered
Joined
·
517 Posts
Get an iPhone FTW :)

Maybe reboot the android... (IDK)

Seriously tho dude I don't know what to tell you to help wish I did... My iphone syncs up perfectly every time, However Ram put some stupid NAV rules in place if the truck is moving you cant do anything, not even your passenger can ...
 

·
Registered
Joined
·
74 Posts
i have a LG G3 and my truck has a problem finding my phone i have go into my bluetooth menu and tell it to connect i own a 2015 ED with a 8.4 and nav maybe there is a problem between LG and RAM software my phone has no problem with my challenger or my bluetooth earpiece
 

·
Super Moderator
Joined
·
2,559 Posts
I also don't have an answer to your problem as I also have an iPhone and have had all types of issues trying to use via mobile and some of the other options. The phone works correctly but the rest? If I want to listen to music I just connect via usb. I have called the worthless Uconnect support also. This is why I didn't renew my subscription when it ran out. It's a shame they can't have a system that works correctly. Hopefully someone will chime in with something to help.
 

·
Registered
Joined
·
517 Posts
My 2014 Charger and 2015 Durango (work vehicles) both with 8.4s connect to my iphone via Bluetooth instantly every time BT is on in my phone.. of course my Ram works good also... They all play music streaming or off music files from phone and offer steering wheel controls . phone calls work with hands free. I wish I knew more about it so I could help you guys to get fixed up..
 

·
Registered
Joined
·
2,979 Posts
It's not because you have a Droid phone. My iPhone does the same crap. U-connect support is so worthless all they can say is take it to the dealer. This was a great system until they decided to sit on their laurels & make zero improvements in three years! I can make & receive calls OK & my iTunes side of my phone doesn't always work right. I asked U-Connect if they were going to offer the new Apple CarPlay & was told that only the new models will get that. So, all of us existing customers are screwed.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
** Update **

A trip to the dealer showed that my phone had the same issue with a random Durango leading me to believe that there is something with LG and uConnect that almost works. It is still strange that everything worked for the 1st week (give or take).

I have also noticed that i can get the phone / uConnect to work properly if i first stream bluetooth from a different source (Amazon vs Google Play vs Audible etc) than i intend to listed to while Google Navigating. It seems the first BlueTooth stream has the issue mentioned in original post, subsequent connections do not. This has to be done each time the truck starts. So at least there is a workaround.

Side note: I have been thinking long and hard and after creating an Excel spreadsheet have determined that it is cheaper to replace the phone than it is to replace the truck.
 

·
Registered
Joined
·
545 Posts
So you are aware, all of the functions you are describing - i.e. playing music, rely on the Phone to handle. For example, when playing music, take a look at your phone - there will be an app open to handle it -> stream it to uconnect. I would suspect the Phone is the issue - there may be too many applications open at one time, and the phone runs out of memory to function.

For Google Maps, you may also want to look at the settings on the Phone. It could be as simple, as voice is turned off in the application itself - therefore nothing will come out of Uconnect, as it receives nothing.

Having said that, it is strange that it works with other vehicles. So the other thing to look at is the Bluetooth settings on the Phone. It may not be giving full access to Uconnect in your RAM, but is allowing it to the other Vehicles you tested in. Look at the BT settings for the vehicles that are working - and do a comparison - see if there is anything turned off/on.

I am also running 5.1.1 (Galaxy S6), but I have not tried some of the features you have listed - pretty much just do Phone/Txt. Will see if I can test my Phone and reproduce what you are seeing.
 

·
Registered
Joined
·
123 Posts
My HTC One Android phone does all things properly... must be your phone?
 

·
Registered
Joined
·
453 Posts
I would say Google nav did an update, and that update did something to the way Bluetooth connections are managed. Similar experience happened on my 14 but it was the opposite. Never voiced, then one day my truck stated talking to me and I thought it was judgement day.
 

·
Registered
Joined
·
331 Posts
Have you tried uninstalling the app and reinstalling it?


Sent from my iPad using Tapatalk
 
1 - 11 of 11 Posts
Top