RAM 1500 Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Had it done yesterday at local dealer in Carlsbad, CA (they said it's required to register w/ DMV next time). Expected the worst but very little changed: a bit sluggish from stop while cold, some change in shifting noted. Not bad so far. Will watch mpg etc..
The problems are with the Settlement claim process:
1) I mailed the claims form after the opening date in May (because online form couldn't be filled in). I called them yesterday and was told no record, so resubmit online.
2) Online PDF NOT FILLABLE W/ WINDOWS 10 on my new computer and app not available to fix.
3) So, I filled in on my phone which went ok until I had to enter my city, state and ZIP. Those 3 items were printed VERTICALLY and the typing boxes were only big enough to show a single (or less) character.
4) I entered anyway (tho I couldn't see entries) and submitted. I did get a claim #.
 

·
Registered
Joined
·
922 Posts
Mike,
I've been using a great free PDF editor called ableword. It will solve your problems dealing with FCA and Windows.
A word of caution. when you get your 8 page agreement that requires your sig and notarized don't send it back as one file. FCA's site can't receive it, too big. Split it up. I sent 4 pages at a time, they got that ok.

AbleWord the Free Word Processor and PDF editor
 

·
Registered
Joined
·
480 Posts
I two had problems sending them my papers. I will try sending it in two parts. Thank you for sharing your knowledge ��
Mike,
I've been using a great free PDF editor called ableword. It will solve your problems dealing with FCA and Windows.
A word of caution. when you get your 8 page agreement that requires your sig and notarized don't send it back as one file. FCA's site can't receive it, too big. Split it up. I sent 4 pages at a time, they got that ok.

AbleWord the Free Word Processor and PDF editor
 

·
Registered
Joined
·
922 Posts
^^^^^ :eek:
 

·
Registered
Joined
·
3 Posts
I just picked up my truck, 2016 eco from having the V08 update and as others have noted the initial lag/sluggishness is present. I will also be keeping an eye on it for any mpg change. I did a search here and couldn't find anyone posting a similar situation as mine, Oil Change Required is now displayed on my instrument cluster. I go in to see the life percentage meter and it properly shows miles since last reset which is only 3586 miles but says life is 0%. I hadn't even left the lot, drove back to service area and talked to the rep helping me. I asked if it was normal or just needed time or mileage to reset itself. He mentioned that it was most likely from the software update. Did not seem very confident about it but I figured i'll put it through some miles and see what happens. I checked the oil level and my oil pan valve to make sure they hadn't farked with anything, levels were good. Also made them top off my coolant and give me a free gallon since they don't have parts available for the egr replacement.
 
1 - 5 of 5 Posts
Top