RAM 1500 Diesel Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
After waiting patiently for 85 days my ram limited ecodiesel finally arrived

On the drive home noticed that when letting off the gas there is a horrible squeal, seemed to get worse as I drove. A block from home the truck started blowing smoke through the vents.

Heading back to dealer now, so far all I can say is its a nice looking truck...

Sent from my LG-D803 using Tapatalk
 

·
Registered
Joined
·
1,337 Posts
I'm sure it's probably just something that wasn't tightened.....they will have your truck back in a hurry!!
 

·
Registered
Joined
·
231 Posts
Wow that sucks. I hope they get it squared away for you.
 

·
Registered
Joined
·
1,845 Posts
My money is on the accessory belt for the spare tire. Most don't realize there is a belt to drive the spare to keep it not only properly inflated, but balanced. When it's out of alignment, things get weird.

...but it could be something else, too...so let us know what they say. ;)
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #7 ·
Took it back to dealer. On the way ran a/c on max the entire drive no smoke (chalk that up to condensation). Sound seemed to diminish a little on the way. Dealer had a listen asked how the engine felt (great minus the noise). Told me to take it out for a solid drive and see if there is any improvement, also told not to be baby it. Did what he asked and it is improving. Going to drive it the rest of week end see what happens.

Sent from my LG-D803 using Tapatalk
 

·
Registered
Joined
·
13,969 Posts
A squeal and smoke is more than "smoke and mirrors". Something broke.

Guess now you will have to run it and see. Your experience is not common.
 

·
Registered
Joined
·
104 Posts
Well that sucks about the problem.

I'm curious, was there any distinguishable odor to the smoke?
Burning rubber, oil, coolant, etc etc.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #10 ·
Truck went back to the dealers. They found manifold bolts loose or completely missing. Easy fix still a pain in the ass.

Sent from my LG-D803 using Tapatalk
 

·
Registered
Joined
·
940 Posts
It's the "completely missing" part that has me concerned... *sigh*
That's the second report like this. Center console was the other.
 

·
Registered
Joined
·
641 Posts
I picked mine up on friday. The GM went out to fuel it for me, when he came back it was dripping fluid. Turned out it was a couple of rad hoses. Easy enough to fix. It will be going back this week to fix a drive line clunk I noticed on the way home.
 

·
Registered
Joined
·
13,969 Posts
Glad they were able to tighten things up for you. Thanks for the update.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #18 ·
No problem captainmal. Just got it home from the dealer, and it's just awesome!

Sent from my LG-D803 using Tapatalk
 

·
Registered
Joined
·
505 Posts
Truck went back to the dealers. They found manifold bolts loose or completely missing. Easy fix still a pain in the ass.

Sent from my LG-D803 using Tapatalk
Let's hope you never have another issue with your EcoD. And let's hope the QC people return from their break.
 
1 - 20 of 21 Posts
Top